Mint: Mint 19 Cinnamon: Install Notes

Linux Mint 19.1 Cinnamon Install Notes
==============================================

Users/Groups
=======================
add admin - setup
add & chmod 777 /home/shares/vm
add /iso , /vm-shared
sudo -H system-config-samba

 

 

 

RDP
=======================
rdesktop -g 1920x1000 -a 16 192.168.0.101

SECURITY CAM
share
smb://WORKGROUP;username@HOSTNAMEORIPADDRESS/PATH

 

 

Software - GUI
=======================
InkScape
VirtualBox
--move to home/shares/vm
--c7.testauto import
--m19.dev.2018.1226 appliance
  --guest additions 5.2.18
  --extensions 5.2.18
  --guest deps for GUest Extensions
    sudo apt-get update
    sudo apt install linux-headers-$(uname -r) build-essential dkms
  -- changed OS from Debianx64 to Ubuntux64
  -- reinstalled Guest Additions
  -- updated 3rd Party Drivers
  Eclipse
  Git : sudo apt install git

KeyPass
FileZilla
Furuisisomount
Audacity
Sublime
Wine32
playonlinux
shutter screencap
gThumb
Shotwell
xxPhotoQt
Handbrake
Rdesktop
xxWinSCP?
Blender
?Gnome Maps
?Scribus
?Skype
?Steam
?Mpv

 

 

208.180.42.68, 208.180.42.100


Rdesktop
------------------
fullscreen: rdesktop -f -a 16 192.168.0.201
1080p:      rdesktop -g 1920x1000 -a 16 192.168.0.201


Software - OS
=======================
System-config-samba
--sudo touch /etc/libuser.conf
--sudo -H system-config-samba
findsmb
--sudo apt install smbclient
Connect to Server & Save Bookmarks
--SILO6 [ L,M,O,P,V

SSH Server
SSH Client
Samba
Putty-tools
vnc

 

 

Dev
=======================
Java1.8x64
  sudo add-apt-repository ppa:webupd8team/java
  sudo apt-get update
  sudo apt-get install oracle-java8-installer
  sudo apt-get install oracle-java8-set-default
  java -version
Eclipse Java
  Natural
  TestNG
  Dark Style
  PHP Dev Tools ( PDT )
  SubClipse
  SoapUI Plugin Manual Config Local Source
  Eclipse COlor Theme

  Eclipse Archive Utility
  YEdit
  JSonEditor
 

  Groovy Dev Tools GDT

 

  PyDev
  Eclipse Tomcat Plugin 9.1.3

 

 

 

PHP 7.22
  sudo apt-get install python-software-properties
  sudo add-apt-repository ppa:ondrej/php
  sudo apt-get update
  sudo apt-get install -y php7.2
  apt-cache search --names-only ^php
  PHP.INI:  COMMENTED THE MODULES OUT PHPUNIT RAN FINE

  php.ini
    memory_limit = 1000M ( from 8M )
    upload_max_filesize = 100M ( from 2M )
    max_execution_time = 600 ( from 30)
    extensions
      mbstring
      curl
      bz2
      openssl
    [opcache]
    ; Determines if Zend OPCache is enabled
    opcache.enable=1

    ; Determines if Zend OPCache is enabled for the CLI version of PHP
    opcache.enable_cli=0

    ; The OPcache shared memory storage size.
    opcache.memory_consumption=128


    FAILING TO RUN COMPOSER-SETUP.PHP
    SO TRYING:
        apt-get install php-pear php-fpm php-dev php-zip php-curl php-xmlrpc php-gd php-mysql php-mbstring php-xml libapache2-mod-php

==================================================
    Might Try some of these???
    ==================================================
    apt-get install php7.2-gd php7.2-bz


    apt-get install php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml

    ==================================================
    NOT YET...
    apt-get install php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml
    ==================================================
    ==================================================
    ORIGINAL SOURCE, NOT USED
    apt-get install php-pear php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml
    ==================================================


    COMMENTED THE MODULES OUT PHPUNIT RAN FINE
    ==================================================

 

==================================================

=====================================================================      
Git
=====================================================================


Composer
Meld

 

=====================================================================
=====================================================================
PHPUnitWebDriver
=====================================================================
=====================================================================

silosix@M6500:~/git/phpunitwebdriver$ php composer-setup.php
PHP Warning:  PHP Startup: Unable to load dynamic library 'bz2' (tried: //usr/lib/php/20170718/bz2 (//usr/lib/php/20170718/bz2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/bz2.so (//usr/lib/php/20170718/bz2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd2' (tried: //usr/lib/php/20170718/gd2 (//usr/lib/php/20170718/gd2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/gd2.so (//usr/lib/php/20170718/gd2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'openssl' (tried: //usr/lib/php/20170718/openssl (//usr/lib/php/20170718/openssl: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/openssl.so (//usr/lib/php/20170718/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0
All settings correct for using Composer
Downloading...

Composer (version 1.8.0) successfully installed to: /home/silosix/git/phpunitwebdriver/composer.phar
Use it: php composer.phar

silosix@M6500:~/git/phpunitwebdriver$ ls
bin            composer.lock  composer.phar.temp  composer-setup.php.temp  README.md  tests
composer.json  composer.phar  composer-setup.php  phpunit.xml              src
silosix@M6500:~/git/phpunitwebdriver$ php composer.phar instalL
PHP Warning:  PHP Startup: Unable to load dynamic library 'bz2' (tried: //usr/lib/php/20170718/bz2 (//usr/lib/php/20170718/bz2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/bz2.so (//usr/lib/php/20170718/bz2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd2' (tried: //usr/lib/php/20170718/gd2 (//usr/lib/php/20170718/gd2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/gd2.so (//usr/lib/php/20170718/gd2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'openssl' (tried: //usr/lib/php/20170718/openssl (//usr/lib/php/20170718/openssl: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/openssl.so (//usr/lib/php/20170718/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0

                                                                  
  [Symfony\Component\Console\Exception\CommandNotFoundException]  
  Command "instalL" is not defined.                               
                                                                  
  Did you mean this?                                              
      install                                                     
                                                                  

silosix@M6500:~/git/phpunitwebdriver$ php composer.phar install
PHP Warning:  PHP Startup: Unable to load dynamic library 'bz2' (tried: //usr/lib/php/20170718/bz2 (//usr/lib/php/20170718/bz2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/bz2.so (//usr/lib/php/20170718/bz2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd2' (tried: //usr/lib/php/20170718/gd2 (//usr/lib/php/20170718/gd2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/gd2.so (//usr/lib/php/20170718/gd2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'openssl' (tried: //usr/lib/php/20170718/openssl (//usr/lib/php/20170718/openssl: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/openssl.so (//usr/lib/php/20170718/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 64 installs, 0 updates, 0 removals
  - Installing behat/gherkin (v4.5.1): Downloading (100%)         
  - Installing symfony/polyfill-mbstring (v1.10.0): Downloading (100%)         
  - Installing symfony/polyfill-ctype (v1.10.0): Downloading (100%)         
  - Installing symfony/dom-crawler (v4.1.8): Downloading (100%)         
  - Installing symfony/browser-kit (v4.1.8): Downloading (100%)         
  - Installing symfony/css-selector (v3.4.19): Downloading (100%)         
  - Installing behat/mink (v1.7.1): Downloading (100%)         
  - Installing behat/mink-browserkit-driver (1.3.3): Downloading (100%)         
  - Installing behat/transliterator (v1.2.0): Downloading (100%)         
  - Installing psr/container (1.0.0): Downloading (100%)         
  - Installing container-interop/container-interop (1.2.0): Downloading (100%)         
  - Installing symfony/polyfill-iconv (v1.10.0): Downloading (100%)         
  - Installing paragonie/random_compat (v2.0.17): Downloading (100%)         
  - Installing drupal/core-utility (8.6.3): Downloading (100%)         
  - Installing drupal/core-render (8.6.3): Downloading (100%)         
  - Installing symfony/event-dispatcher (v3.4.19): Downloading (100%)         
  - Installing symfony/dependency-injection (v3.4.19): Downloading (100%)         
  - Installing symfony/process (v3.4.19): Downloading (100%)         
  - Installing drupal/drupal-driver (v1.4.0): Downloading (100%)         
  - Installing instaclick/php-webdriver (1.4.5): Downloading (100%)         
  - Installing behat/mink-selenium2-driver (v1.3.1): Downloading (100%)         
  - Installing psr/http-message (1.0.1): Downloading (100%)         
  - Installing guzzlehttp/psr7 (1.4.2): Downloading (100%)         
  - Installing guzzlehttp/promises (v1.3.1): Downloading (100%)         
  - Installing guzzlehttp/guzzle (dev-master 8db1967): Cloning 8db1967d92
    Failed to download guzzlehttp/guzzle from source: Failed to clone https://github.com/guzzle/guzzle.git, git was not found, check that it is installed and in your PATH env.

sh: 1: git: not found

    Now trying to download from dist
  - Installing guzzlehttp/guzzle (dev-master 8db1967): Downloading (100%)         
  - Installing fabpot/goutte (v3.2.3): Downloading (100%)         
  - Installing behat/mink-goutte-driver (v1.2.1): Downloading (100%)         
  - Installing symfony/filesystem (v4.1.8): Downloading (100%)         
  - Installing symfony/config (v4.1.8): Downloading (100%)         
  - Installing symfony/yaml (v4.1.8): Downloading (100%)         
  - Installing symfony/translation (v4.1.8): Downloading (100%)         
  - Installing symfony/console (v4.1.8): Downloading (100%)         
  - Installing symfony/class-loader (v3.4.19): Downloading (100%)         
  - Installing behat/behat (v3.5.0): Downloading (100%)         
    Skipped installation of bin bin/behat for package behat/behat: name conflicts with an existing file
  - Installing behat/mink-extension (2.3.1): Downloading (100%)         
  - Installing drupal/drupal-extension (v3.4.1): Downloading (100%)         
  - Installing facebook/webdriver (1.6.0): Downloading (100%)         
  - Installing webmozart/assert (1.3.0): Downloading (100%)         
  - Installing phpdocumentor/reflection-common (1.0.1): Downloading (100%)         
  - Installing phpdocumentor/type-resolver (0.4.0): Downloading (100%)         
  - Installing phpdocumentor/reflection-docblock (4.3.0): Downloading (100%)         
  - Installing phpunit/php-token-stream (3.0.1): Downloading (100%)         
  - Installing sebastian/version (2.0.1): Downloading (100%)         
  - Installing sebastian/resource-operations (2.0.1): Downloading (100%)         
  - Installing sebastian/recursion-context (3.0.0): Downloading (100%)         
  - Installing sebastian/object-reflector (1.1.1): Downloading (100%)         
  - Installing sebastian/object-enumerator (3.0.3): Downloading (100%)         
  - Installing sebastian/global-state (2.0.0): Downloading (100%)         
  - Installing sebastian/exporter (3.1.0): Downloading (100%)         
  - Installing sebastian/environment (4.0.1): Downloading (100%)         
  - Installing sebastian/diff (3.0.1): Downloading (100%)         
  - Installing sebastian/comparator (3.0.2): Downloading (100%)         
  - Installing phpunit/php-timer (2.0.0): Downloading (100%)         
  - Installing phpunit/php-text-template (1.2.1): Downloading (100%)         
  - Installing phpunit/php-file-iterator (2.0.2): Downloading (100%)         
  - Installing theseer/tokenizer (1.1.0): Downloading (100%)         
  - Installing sebastian/code-unit-reverse-lookup (1.0.1): Downloading (100%)         
  - Installing phpunit/php-code-coverage (6.1.4): Downloading (100%)         
  - Installing doctrine/instantiator (1.1.0): Downloading (100%)         
  - Installing phpspec/prophecy (1.8.0): Downloading (100%)         
  - Installing phar-io/version (2.0.1): Downloading (100%)         
  - Installing phar-io/manifest (1.0.3): Downloading (100%)         
  - Installing myclabs/deep-copy (1.8.1): Downloading (100%)         
  - Installing phpunit/phpunit (7.4.4): Downloading (100%)         
    Skipped installation of bin phpunit for package phpunit/phpunit: name conflicts with an existing file
behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled headless driver for any app (requires node.js))
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
symfony/event-dispatcher suggests installing symfony/http-kernel
symfony/dependency-injection suggests installing symfony/expression-language (For using expressions in service container configuration)
symfony/dependency-injection suggests installing symfony/finder (For using double-star glob patterns or when GLOB_BRACE portability is required)
symfony/dependency-injection suggests installing symfony/proxy-manager-bridge (Generate service proxies to lazy load them)
guzzlehttp/guzzle suggests installing psr/log (Required for using the Log middleware)
symfony/translation suggests installing psr/log-implementation (To use logging capability in translator)
symfony/console suggests installing psr/log-implementation (For using the console logger)
symfony/console suggests installing symfony/lock
symfony/class-loader suggests installing symfony/polyfill-apcu (For using ApcClassLoader on HHVM)
facebook/webdriver suggests installing ext-SimpleXML (For Firefox profile creation)
sebastian/global-state suggests installing ext-uopz (*)
phpunit/php-code-coverage suggests installing ext-xdebug (^2.6.0)
phpunit/phpunit suggests installing ext-soap (*)
phpunit/phpunit suggests installing ext-xdebug (*)
phpunit/phpunit suggests installing phpunit/php-invoker (^2.0)
Generating autoload files

 

 


=====================================================================
=====================================================================

SESSIONS

=====================================================================
=====================================================================
setup@M6500:~/Downloads$ find wine
find: ‘wine’: No such file or directory
setup@M6500:~/Downloads$ find wine-stable
find: ‘wine-stable’: No such file or directory
setup@M6500:~/Downloads$ which wine-stable
/usr/bin/wine-stable
setup@M6500:~/Downloads$ /usr/bin/wine-stable
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"
Usage: wine PROGRAM [ARGUMENTS...]   Run the specified program
       wine --help                   Display this help and exit
       wine --version                Output version information and exit
setup@M6500:~/Downloads$ cd ..
setup@M6500:~$ sudo apt-get install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package winehq-stable
setup@M6500:~$ apt-get install wine32
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
setup@M6500:~$ sudo apt-get install wine32
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gcc-8-base:i386 libasn1-8-heimdal:i386 libasound2:i386 libasyncns0:i386
  libblkid1:i386 libbsd0:i386 libc6:i386 libcap2:i386 libcom-err2:i386
  libdb5.3:i386 libdbus-1-3:i386 libexif12:i386 libexpat1:i386 libffi6:i386
  libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386
  libgcrypt20:i386 libgd3:i386 libglib2.0-0:i386 libgmp10:i386
  libgnutls30:i386 libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port12:i386
  libgssapi3-heimdal:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhogweed4:i386 libhx509-5-heimdal:i386
  libicu60:i386 libidn2-0:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
  libkrb5-26-heimdal:i386 liblcms2-2:i386 libldap-2.4-2:i386 libltdl7:i386
  liblz4-1:i386 liblzma5:i386 libmount1:i386 libmpg123-0:i386 libncurses5:i386
  libnettle6:i386 libogg0:i386 libopenal1:i386 liborc-0.4-0:i386
  libp11-kit0:i386 libpcap0.8:i386 libpcre3:i386 libpng16-16:i386
  libpulse0:i386 libroken18-heimdal:i386 libsasl2-2:i386
  libsasl2-modules-db:i386 libselinux1:i386 libsndfile1:i386 libsndio6.1:i386
  libsqlite3-0:i386 libstdc++6:i386 libsystemd0:i386 libtasn1-6:i386
  libtiff5:i386 libtinfo5:i386 libudev1:i386 libunistring2:i386
  libusb-1.0-0:i386 libuuid1:i386 libvorbis0a:i386 libvorbisenc2:i386
  libwebp6:i386 libwind0-heimdal:i386 libwine:i386 libwrap0:i386 libx11-6:i386
  libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxml2:i386
  libxpm4:i386 ocl-icd-libopencl1:i386 zlib1g:i386
Suggested packages:
  libasound2-plugins:i386 glibc-doc:i386 locales:i386 rng-tools:i386
  libgd-tools:i386 gnutls-bin:i386 gphoto2:i386 libvisual-0.4-plugins:i386
  gstreamer1.0-tools:i386 libportaudio2:i386 sndiod:i386
  ttf-mscorefonts-installer:i386 opencl-icd:i386 libwine-gecko-2.47:i386
  wine32-preloader:i386
Recommended packages:
  gstreamer1.0-plugins-base:i386 libgpm2:i386 libsasl2-modules:i386
  libcapi20-3:i386 libcups2:i386 libgl1-mesa-glx:i386 | libgl1:i386
  libglu1-mesa:i386 | libglu1:i386 libgsm1:i386 libkrb5-3:i386 libodbc1:i386
  libosmesa6:i386 libsane1:i386 libv4l-0:i386 libxcomposite1:i386
  libxcursor1:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
  libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxxf86vm1:i386
  libgl1-mesa-dri:i386 libasound2-plugins:i386 fonts-wine:i386
The following NEW packages will be installed:
  gcc-8-base:i386 libasn1-8-heimdal:i386 libasound2:i386 libasyncns0:i386
  libblkid1:i386 libbsd0:i386 libc6:i386 libcap2:i386 libcom-err2:i386
  libdb5.3:i386 libdbus-1-3:i386 libexif12:i386 libexpat1:i386 libffi6:i386
  libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libgcc1:i386
  libgcrypt20:i386 libgd3:i386 libglib2.0-0:i386 libgmp10:i386
  libgnutls30:i386 libgpg-error0:i386 libgphoto2-6:i386 libgphoto2-port12:i386
  libgssapi3-heimdal:i386 libgstreamer-plugins-base1.0-0:i386
  libgstreamer1.0-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhogweed4:i386 libhx509-5-heimdal:i386
  libicu60:i386 libidn2-0:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
  libkrb5-26-heimdal:i386 liblcms2-2:i386 libldap-2.4-2:i386 libltdl7:i386
  liblz4-1:i386 liblzma5:i386 libmount1:i386 libmpg123-0:i386 libncurses5:i386
  libnettle6:i386 libogg0:i386 libopenal1:i386 liborc-0.4-0:i386
  libp11-kit0:i386 libpcap0.8:i386 libpcre3:i386 libpng16-16:i386
  libpulse0:i386 libroken18-heimdal:i386 libsasl2-2:i386
  libsasl2-modules-db:i386 libselinux1:i386 libsndfile1:i386 libsndio6.1:i386
  libsqlite3-0:i386 libstdc++6:i386 libsystemd0:i386 libtasn1-6:i386
  libtiff5:i386 libtinfo5:i386 libudev1:i386 libunistring2:i386
  libusb-1.0-0:i386 libuuid1:i386 libvorbis0a:i386 libvorbisenc2:i386
  libwebp6:i386 libwind0-heimdal:i386 libwine:i386 libwrap0:i386 libx11-6:i386
  libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxml2:i386
  libxpm4:i386 ocl-icd-libopencl1:i386 wine32:i386 zlib1g:i386
0 upgraded, 89 newly installed, 0 to remove and 93 not upgraded.
Need to get 45.9 MB of archives.
After this operation, 280 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 gcc-8-base i386 8.2.0-1ubuntu2~18.04 [18.3 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libgcc1 i386 1:8.2.0-1ubuntu2~18.04 [48.1 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main i386 libc6 i386 2.27-3ubuntu1 [2,551 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main i386 libgpg-error0 i386 1.27-6 [41.4 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libgcrypt20 i386 1.8.1-4ubuntu1.1 [399 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/main i386 liblz4-1 i386 0.0~r131-2ubuntu3 [39.1 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main i386 liblzma5 i386 5.2.2-1.3 [98.5 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libsystemd0 i386 237-3ubuntu10.9 [221 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic/main i386 libxau6 i386 1:1.0.8-1 [8,352 B]
Get:10 http://archive.ubuntu.com/ubuntu bionic/main i386 libbsd0 i386 0.8.7-1 [44.7 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic/main i386 libxdmcp6 i386 1:1.1.2-3 [11.1 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic/main i386 libxcb1 i386 1.13-1 [50.0 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libx11-6 i386 2:1.6.4-3ubuntu0.1 [595 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic/main i386 libxext6 i386 2:1.3.3-1 [31.6 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libjpeg-turbo8 i386 1.5.2-0ubuntu5.18.04.1 [118 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic/main i386 libogg0 i386 1.3.2-1 [16.2 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libuuid1 i386 2.31.1-0.4ubuntu3.2 [20.8 kB]
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libblkid1 i386 2.31.1-0.4ubuntu3.2 [140 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic/main i386 libcom-err2 i386 1.44.1-1 [10.2 kB]
Get:20 http://archive.ubuntu.com/ubuntu bionic/main i386 libdb5.3 i386 5.3.28-13.1ubuntu1 [738 kB]
Get:21 http://archive.ubuntu.com/ubuntu bionic/main i386 libpcre3 i386 2:8.39-9 [228 kB]
Get:22 http://archive.ubuntu.com/ubuntu bionic/main i386 libselinux1 i386 2.7-2build2 [72.9 kB]
Get:23 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libmount1 i386 2.31.1-0.4ubuntu3.2 [149 kB]
Get:24 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libtinfo5 i386 6.1-1ubuntu1.18.04 [80.4 kB]
Get:25 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libncurses5 i386 6.1-1ubuntu1.18.04 [101 kB]
Get:26 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libudev1 i386 237-3ubuntu10.9 [57.4 kB]
Get:27 http://archive.ubuntu.com/ubuntu bionic/main i386 zlib1g i386 1:1.2.11.dfsg-0ubuntu2 [58.2 kB]
Get:28 http://archive.ubuntu.com/ubuntu bionic/main i386 libcap2 i386 1:2.25-1.2 [13.4 kB]
Get:29 http://archive.ubuntu.com/ubuntu bionic/main i386 libdbus-1-3 i386 1.12.2-1ubuntu1 [188 kB]
Get:30 http://archive.ubuntu.com/ubuntu bionic/main i386 libexpat1 i386 2.2.5-3 [78.1 kB]
Get:31 http://archive.ubuntu.com/ubuntu bionic/main i386 libffi6 i386 3.2.1-8 [17.2 kB]
Get:32 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libglib2.0-0 i386 2.56.3-0ubuntu0.18.04.1 [1,234 kB]
Get:33 http://archive.ubuntu.com/ubuntu bionic/main i386 libgmp10 i386 2:6.1.2+dfsg-2 [246 kB]
Get:34 http://archive.ubuntu.com/ubuntu bionic/main i386 libnettle6 i386 3.4-1 [127 kB]
Get:35 http://archive.ubuntu.com/ubuntu bionic/main i386 libhogweed4 i386 3.4-1 [139 kB]
Get:36 http://archive.ubuntu.com/ubuntu bionic/main i386 libunistring2 i386 0.9.9-0ubuntu1 [385 kB]
Get:37 http://archive.ubuntu.com/ubuntu bionic/main i386 libidn2-0 i386 2.0.4-1.1build2 [48.7 kB]
Get:38 http://archive.ubuntu.com/ubuntu bionic/main i386 libp11-kit0 i386 0.23.9-2 [185 kB]
Get:39 http://archive.ubuntu.com/ubuntu bionic/main i386 libtasn1-6 i386 4.13-2 [38.8 kB]
Get:40 http://archive.ubuntu.com/ubuntu bionic/main i386 libgnutls30 i386 3.5.18-1ubuntu1 [659 kB]
Get:41 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libstdc++6 i386 8.2.0-1ubuntu2~18.04 [430 kB]
Get:42 http://archive.ubuntu.com/ubuntu bionic/main i386 libicu60 i386 60.2-3ubuntu3 [8,193 kB]
Get:43 http://archive.ubuntu.com/ubuntu bionic/main i386 libsqlite3-0 i386 3.22.0-1 [531 kB]
Get:44 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libxml2 i386 2.9.4+dfsg1-6.1ubuntu1.2 [698 kB]
Get:45 http://archive.ubuntu.com/ubuntu bionic/main i386 libpcap0.8 i386 1.8.1-6ubuntu1 [124 kB]
Get:46 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libpng16-16 i386 1.6.34-1ubuntu0.18.04.1 [184 kB]
Get:47 http://archive.ubuntu.com/ubuntu bionic/main i386 libusb-1.0-0 i386 2:1.0.21-2 [46.7 kB]
Get:48 http://archive.ubuntu.com/ubuntu bionic/main i386 libroken18-heimdal i386 7.5.0+dfsg-1 [44.8 kB]
Get:49 http://archive.ubuntu.com/ubuntu bionic/main i386 libasn1-8-heimdal i386 7.5.0+dfsg-1 [183 kB]
Get:50 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libasound2 i386 1.1.3-5ubuntu0.1 [381 kB]
Get:51 http://archive.ubuntu.com/ubuntu bionic/main i386 libasyncns0 i386 0.8-6 [12.5 kB]
Get:52 http://archive.ubuntu.com/ubuntu bionic/main i386 libexif12 i386 0.6.21-4 [76.0 kB]
Get:53 http://archive.ubuntu.com/ubuntu bionic/main i386 libflac8 i386 1.3.2-1 [152 kB]
Get:54 http://archive.ubuntu.com/ubuntu bionic/main i386 libfreetype6 i386 2.8.1-2ubuntu2 [351 kB]
Get:55 http://archive.ubuntu.com/ubuntu bionic/main i386 libfontconfig1 i386 2.12.6-0ubuntu2 [146 kB]
Get:56 http://archive.ubuntu.com/ubuntu bionic/main i386 libjpeg8 i386 8c-2ubuntu8 [2,188 B]
Get:57 http://archive.ubuntu.com/ubuntu bionic/main i386 libjbig0 i386 2.1-3.1build1 [27.3 kB]
Get:58 http://archive.ubuntu.com/ubuntu bionic/main i386 libtiff5 i386 4.0.9-5 [164 kB]
Get:59 http://archive.ubuntu.com/ubuntu bionic/main i386 libwebp6 i386 0.6.1-2 [197 kB]
Get:60 http://archive.ubuntu.com/ubuntu bionic/main i386 libxpm4 i386 1:3.5.12-1 [35.8 kB]
Get:61 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libgd3 i386 2.2.5-4ubuntu0.2 [123 kB]
Get:62 http://archive.ubuntu.com/ubuntu bionic/main i386 libltdl7 i386 2.4.6-2 [40.5 kB]
Get:63 http://archive.ubuntu.com/ubuntu bionic/main i386 libgphoto2-port12 i386 2.5.16-2 [52.0 kB]
Get:64 http://archive.ubuntu.com/ubuntu bionic/main i386 libgphoto2-6 i386 2.5.16-2 [860 kB]
Get:65 http://archive.ubuntu.com/ubuntu bionic/main i386 libheimbase1-heimdal i386 7.5.0+dfsg-1 [32.1 kB]
Get:66 http://archive.ubuntu.com/ubuntu bionic/main i386 libhcrypto4-heimdal i386 7.5.0+dfsg-1 [92.6 kB]
Get:67 http://archive.ubuntu.com/ubuntu bionic/main i386 libwind0-heimdal i386 7.5.0+dfsg-1 [48.3 kB]
Get:68 http://archive.ubuntu.com/ubuntu bionic/main i386 libhx509-5-heimdal i386 7.5.0+dfsg-1 [118 kB]
Get:69 http://archive.ubuntu.com/ubuntu bionic/main i386 libkrb5-26-heimdal i386 7.5.0+dfsg-1 [232 kB]
Get:70 http://archive.ubuntu.com/ubuntu bionic/main i386 libheimntlm0-heimdal i386 7.5.0+dfsg-1 [16.4 kB]
Get:71 http://archive.ubuntu.com/ubuntu bionic/main i386 libgssapi3-heimdal i386 7.5.0+dfsg-1 [106 kB]
Get:72 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libgstreamer1.0-0 i386 1.14.1-1~ubuntu18.04.1 [892 kB]
Get:73 http://archive.ubuntu.com/ubuntu bionic/main i386 liborc-0.4-0 i386 1:0.4.28-1 [148 kB]                                                                                                                                               
Get:74 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libgstreamer-plugins-base1.0-0 i386 1.14.1-1ubuntu1~ubuntu18.04.1 [704 kB]                                                                                                  
Get:75 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 liblcms2-2 i386 2.9-1ubuntu0.1 [150 kB]                                                                                                                                     
Get:76 http://archive.ubuntu.com/ubuntu bionic/main i386 libsasl2-modules-db i386 2.1.27~101-g0780600+dfsg-3ubuntu2 [15.6 kB]                                                                                                                
Get:77 http://archive.ubuntu.com/ubuntu bionic/main i386 libsasl2-2 i386 2.1.27~101-g0780600+dfsg-3ubuntu2 [52.8 kB]                                                                                                                         
Get:78 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libldap-2.4-2 i386 2.4.45+dfsg-1ubuntu1.1 [167 kB]                                                                                                                          
Get:79 http://archive.ubuntu.com/ubuntu bionic/main i386 libmpg123-0 i386 1.25.10-1 [129 kB]                                                                                                                                                 
Get:80 http://archive.ubuntu.com/ubuntu bionic/main i386 libvorbis0a i386 1.3.5-4.2 [84.4 kB]                                                                                                                                                
Get:81 http://archive.ubuntu.com/ubuntu bionic/main i386 libvorbisenc2 i386 1.3.5-4.2 [64.5 kB]                                                                                                                                              
Get:82 http://archive.ubuntu.com/ubuntu bionic/main i386 libsndfile1 i386 1.0.28-4 [191 kB]                                                                                                                                                  
Get:83 http://archive.ubuntu.com/ubuntu bionic/main i386 libwrap0 i386 7.6.q-27 [47.2 kB]                                                                                                                                                    
Get:84 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libpulse0 i386 1:11.1-1ubuntu7.1 [270 kB]                                                                                                                                   
Get:85 http://archive.ubuntu.com/ubuntu bionic/universe i386 libsndio6.1 i386 1.1.0-3 [25.5 kB]                                                                                                                                              
Get:86 http://archive.ubuntu.com/ubuntu bionic/universe i386 libopenal1 i386 1:1.18.2-2 [273 kB]                                                                                                                                             
Get:87 http://archive.ubuntu.com/ubuntu bionic/main i386 ocl-icd-libopencl1 i386 2.2.11-1ubuntu1 [31.3 kB]                                                                                                                                   
Get:88 http://archive.ubuntu.com/ubuntu bionic/universe i386 libwine i386 3.0-1ubuntu1 [19.5 MB]                                                                                                                                             
Get:89 http://archive.ubuntu.com/ubuntu bionic/universe i386 wine32 i386 3.0-1ubuntu1 [196 kB]                                                                                                                                               
Fetched 45.9 MB in 8s (5,423 kB/s)                                                                                                                                                                                                           
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package gcc-8-base:i386.
(Reading database ... 256207 files and directories currently installed.)
Preparing to unpack .../0-gcc-8-base_8.2.0-1ubuntu2~18.04_i386.deb ...
Unpacking gcc-8-base:i386 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libgcc1:i386.
Preparing to unpack .../1-libgcc1_1%3a8.2.0-1ubuntu2~18.04_i386.deb ...
Unpacking libgcc1:i386 (1:8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libc6:i386.
Preparing to unpack .../2-libc6_2.27-3ubuntu1_i386.deb ...
Unpacking libc6:i386 (2.27-3ubuntu1) ...
Selecting previously unselected package libgpg-error0:i386.
Preparing to unpack .../3-libgpg-error0_1.27-6_i386.deb ...
Unpacking libgpg-error0:i386 (1.27-6) ...
Selecting previously unselected package libgcrypt20:i386.
Preparing to unpack .../4-libgcrypt20_1.8.1-4ubuntu1.1_i386.deb ...
Unpacking libgcrypt20:i386 (1.8.1-4ubuntu1.1) ...
Selecting previously unselected package liblz4-1:i386.
Preparing to unpack .../5-liblz4-1_0.0~r131-2ubuntu3_i386.deb ...
Unpacking liblz4-1:i386 (0.0~r131-2ubuntu3) ...
Selecting previously unselected package liblzma5:i386.
Preparing to unpack .../6-liblzma5_5.2.2-1.3_i386.deb ...
Unpacking liblzma5:i386 (5.2.2-1.3) ...
Setting up gcc-8-base:i386 (8.2.0-1ubuntu2~18.04) ...
Setting up libgcc1:i386 (1:8.2.0-1ubuntu2~18.04) ...
Setting up libc6:i386 (2.27-3ubuntu1) ...
Setting up libgpg-error0:i386 (1.27-6) ...
Setting up libgcrypt20:i386 (1.8.1-4ubuntu1.1) ...
Setting up liblz4-1:i386 (0.0~r131-2ubuntu3) ...
Setting up liblzma5:i386 (5.2.2-1.3) ...
Selecting previously unselected package libsystemd0:i386.
(Reading database ... 256524 files and directories currently installed.)
Preparing to unpack .../00-libsystemd0_237-3ubuntu10.9_i386.deb ...
Unpacking libsystemd0:i386 (237-3ubuntu10.9) ...
Selecting previously unselected package libxau6:i386.
Preparing to unpack .../01-libxau6_1%3a1.0.8-1_i386.deb ...
Unpacking libxau6:i386 (1:1.0.8-1) ...
Selecting previously unselected package libbsd0:i386.
Preparing to unpack .../02-libbsd0_0.8.7-1_i386.deb ...
Unpacking libbsd0:i386 (0.8.7-1) ...
Selecting previously unselected package libxdmcp6:i386.
Preparing to unpack .../03-libxdmcp6_1%3a1.1.2-3_i386.deb ...
Unpacking libxdmcp6:i386 (1:1.1.2-3) ...
Selecting previously unselected package libxcb1:i386.
Preparing to unpack .../04-libxcb1_1.13-1_i386.deb ...
Unpacking libxcb1:i386 (1.13-1) ...
Selecting previously unselected package libx11-6:i386.
Preparing to unpack .../05-libx11-6_2%3a1.6.4-3ubuntu0.1_i386.deb ...
Unpacking libx11-6:i386 (2:1.6.4-3ubuntu0.1) ...
Selecting previously unselected package libxext6:i386.
Preparing to unpack .../06-libxext6_2%3a1.3.3-1_i386.deb ...
Unpacking libxext6:i386 (2:1.3.3-1) ...
Selecting previously unselected package libjpeg-turbo8:i386.
Preparing to unpack .../07-libjpeg-turbo8_1.5.2-0ubuntu5.18.04.1_i386.deb ...
Unpacking libjpeg-turbo8:i386 (1.5.2-0ubuntu5.18.04.1) ...
Selecting previously unselected package libogg0:i386.
Preparing to unpack .../08-libogg0_1.3.2-1_i386.deb ...
Unpacking libogg0:i386 (1.3.2-1) ...
Selecting previously unselected package libuuid1:i386.
Preparing to unpack .../09-libuuid1_2.31.1-0.4ubuntu3.2_i386.deb ...
Unpacking libuuid1:i386 (2.31.1-0.4ubuntu3.2) ...
Selecting previously unselected package libblkid1:i386.
Preparing to unpack .../10-libblkid1_2.31.1-0.4ubuntu3.2_i386.deb ...
Unpacking libblkid1:i386 (2.31.1-0.4ubuntu3.2) ...
Selecting previously unselected package libcom-err2:i386.
Preparing to unpack .../11-libcom-err2_1.44.1-1_i386.deb ...
Unpacking libcom-err2:i386 (1.44.1-1) ...
Selecting previously unselected package libdb5.3:i386.
Preparing to unpack .../12-libdb5.3_5.3.28-13.1ubuntu1_i386.deb ...
Unpacking libdb5.3:i386 (5.3.28-13.1ubuntu1) ...
Selecting previously unselected package libpcre3:i386.
Preparing to unpack .../13-libpcre3_2%3a8.39-9_i386.deb ...
Unpacking libpcre3:i386 (2:8.39-9) ...
Selecting previously unselected package libselinux1:i386.
Preparing to unpack .../14-libselinux1_2.7-2build2_i386.deb ...
Unpacking libselinux1:i386 (2.7-2build2) ...
Selecting previously unselected package libmount1:i386.
Preparing to unpack .../15-libmount1_2.31.1-0.4ubuntu3.2_i386.deb ...
Unpacking libmount1:i386 (2.31.1-0.4ubuntu3.2) ...
Selecting previously unselected package libtinfo5:i386.
Preparing to unpack .../16-libtinfo5_6.1-1ubuntu1.18.04_i386.deb ...
Unpacking libtinfo5:i386 (6.1-1ubuntu1.18.04) ...
Selecting previously unselected package libncurses5:i386.
Preparing to unpack .../17-libncurses5_6.1-1ubuntu1.18.04_i386.deb ...
Unpacking libncurses5:i386 (6.1-1ubuntu1.18.04) ...
Selecting previously unselected package libudev1:i386.
Preparing to unpack .../18-libudev1_237-3ubuntu10.9_i386.deb ...
Unpacking libudev1:i386 (237-3ubuntu10.9) ...
Selecting previously unselected package zlib1g:i386.
Preparing to unpack .../19-zlib1g_1%3a1.2.11.dfsg-0ubuntu2_i386.deb ...
Unpacking zlib1g:i386 (1:1.2.11.dfsg-0ubuntu2) ...
Selecting previously unselected package libcap2:i386.
Preparing to unpack .../20-libcap2_1%3a2.25-1.2_i386.deb ...
Unpacking libcap2:i386 (1:2.25-1.2) ...
Selecting previously unselected package libdbus-1-3:i386.
Preparing to unpack .../21-libdbus-1-3_1.12.2-1ubuntu1_i386.deb ...
Unpacking libdbus-1-3:i386 (1.12.2-1ubuntu1) ...
Selecting previously unselected package libexpat1:i386.
Preparing to unpack .../22-libexpat1_2.2.5-3_i386.deb ...
Unpacking libexpat1:i386 (2.2.5-3) ...
Selecting previously unselected package libffi6:i386.
Preparing to unpack .../23-libffi6_3.2.1-8_i386.deb ...
Unpacking libffi6:i386 (3.2.1-8) ...
Selecting previously unselected package libglib2.0-0:i386.
Preparing to unpack .../24-libglib2.0-0_2.56.3-0ubuntu0.18.04.1_i386.deb ...
Unpacking libglib2.0-0:i386 (2.56.3-0ubuntu0.18.04.1) ...
Selecting previously unselected package libgmp10:i386.
Preparing to unpack .../25-libgmp10_2%3a6.1.2+dfsg-2_i386.deb ...
Unpacking libgmp10:i386 (2:6.1.2+dfsg-2) ...
Selecting previously unselected package libnettle6:i386.
Preparing to unpack .../26-libnettle6_3.4-1_i386.deb ...
Unpacking libnettle6:i386 (3.4-1) ...
Selecting previously unselected package libhogweed4:i386.
Preparing to unpack .../27-libhogweed4_3.4-1_i386.deb ...
Unpacking libhogweed4:i386 (3.4-1) ...
Selecting previously unselected package libunistring2:i386.
Preparing to unpack .../28-libunistring2_0.9.9-0ubuntu1_i386.deb ...
Unpacking libunistring2:i386 (0.9.9-0ubuntu1) ...
Selecting previously unselected package libidn2-0:i386.
Preparing to unpack .../29-libidn2-0_2.0.4-1.1build2_i386.deb ...
Unpacking libidn2-0:i386 (2.0.4-1.1build2) ...
Selecting previously unselected package libp11-kit0:i386.
Preparing to unpack .../30-libp11-kit0_0.23.9-2_i386.deb ...
Unpacking libp11-kit0:i386 (0.23.9-2) ...
Selecting previously unselected package libtasn1-6:i386.
Preparing to unpack .../31-libtasn1-6_4.13-2_i386.deb ...
Unpacking libtasn1-6:i386 (4.13-2) ...
Selecting previously unselected package libgnutls30:i386.
Preparing to unpack .../32-libgnutls30_3.5.18-1ubuntu1_i386.deb ...
Unpacking libgnutls30:i386 (3.5.18-1ubuntu1) ...
Selecting previously unselected package libstdc++6:i386.
Preparing to unpack .../33-libstdc++6_8.2.0-1ubuntu2~18.04_i386.deb ...
Unpacking libstdc++6:i386 (8.2.0-1ubuntu2~18.04) ...
Selecting previously unselected package libicu60:i386.
Preparing to unpack .../34-libicu60_60.2-3ubuntu3_i386.deb ...
Unpacking libicu60:i386 (60.2-3ubuntu3) ...
Selecting previously unselected package libsqlite3-0:i386.
Preparing to unpack .../35-libsqlite3-0_3.22.0-1_i386.deb ...
Unpacking libsqlite3-0:i386 (3.22.0-1) ...
Selecting previously unselected package libxml2:i386.
Preparing to unpack .../36-libxml2_2.9.4+dfsg1-6.1ubuntu1.2_i386.deb ...
Unpacking libxml2:i386 (2.9.4+dfsg1-6.1ubuntu1.2) ...
Selecting previously unselected package libpcap0.8:i386.
Preparing to unpack .../37-libpcap0.8_1.8.1-6ubuntu1_i386.deb ...
Unpacking libpcap0.8:i386 (1.8.1-6ubuntu1) ...
Selecting previously unselected package libpng16-16:i386.
Preparing to unpack .../38-libpng16-16_1.6.34-1ubuntu0.18.04.1_i386.deb ...
Unpacking libpng16-16:i386 (1.6.34-1ubuntu0.18.04.1) ...
Selecting previously unselected package libusb-1.0-0:i386.
Preparing to unpack .../39-libusb-1.0-0_2%3a1.0.21-2_i386.deb ...
Unpacking libusb-1.0-0:i386 (2:1.0.21-2) ...
Selecting previously unselected package libroken18-heimdal:i386.
Preparing to unpack .../40-libroken18-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libroken18-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libasn1-8-heimdal:i386.
Preparing to unpack .../41-libasn1-8-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libasn1-8-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libasound2:i386.
Preparing to unpack .../42-libasound2_1.1.3-5ubuntu0.1_i386.deb ...
Unpacking libasound2:i386 (1.1.3-5ubuntu0.1) ...
Selecting previously unselected package libasyncns0:i386.
Preparing to unpack .../43-libasyncns0_0.8-6_i386.deb ...
Unpacking libasyncns0:i386 (0.8-6) ...
Selecting previously unselected package libexif12:i386.
Preparing to unpack .../44-libexif12_0.6.21-4_i386.deb ...
Unpacking libexif12:i386 (0.6.21-4) ...
Selecting previously unselected package libflac8:i386.
Preparing to unpack .../45-libflac8_1.3.2-1_i386.deb ...
Unpacking libflac8:i386 (1.3.2-1) ...
Selecting previously unselected package libfreetype6:i386.
Preparing to unpack .../46-libfreetype6_2.8.1-2ubuntu2_i386.deb ...
Unpacking libfreetype6:i386 (2.8.1-2ubuntu2) ...
Selecting previously unselected package libfontconfig1:i386.
Preparing to unpack .../47-libfontconfig1_2.12.6-0ubuntu2_i386.deb ...
Unpacking libfontconfig1:i386 (2.12.6-0ubuntu2) ...
Selecting previously unselected package libjpeg8:i386.
Preparing to unpack .../48-libjpeg8_8c-2ubuntu8_i386.deb ...
Unpacking libjpeg8:i386 (8c-2ubuntu8) ...
Selecting previously unselected package libjbig0:i386.
Preparing to unpack .../49-libjbig0_2.1-3.1build1_i386.deb ...
Unpacking libjbig0:i386 (2.1-3.1build1) ...
Selecting previously unselected package libtiff5:i386.
Preparing to unpack .../50-libtiff5_4.0.9-5_i386.deb ...
Unpacking libtiff5:i386 (4.0.9-5) ...
Selecting previously unselected package libwebp6:i386.
Preparing to unpack .../51-libwebp6_0.6.1-2_i386.deb ...
Unpacking libwebp6:i386 (0.6.1-2) ...
Selecting previously unselected package libxpm4:i386.
Preparing to unpack .../52-libxpm4_1%3a3.5.12-1_i386.deb ...
Unpacking libxpm4:i386 (1:3.5.12-1) ...
Selecting previously unselected package libgd3:i386.
Preparing to unpack .../53-libgd3_2.2.5-4ubuntu0.2_i386.deb ...
Unpacking libgd3:i386 (2.2.5-4ubuntu0.2) ...
Selecting previously unselected package libltdl7:i386.
Preparing to unpack .../54-libltdl7_2.4.6-2_i386.deb ...
Unpacking libltdl7:i386 (2.4.6-2) ...
Selecting previously unselected package libgphoto2-port12:i386.
Preparing to unpack .../55-libgphoto2-port12_2.5.16-2_i386.deb ...
Unpacking libgphoto2-port12:i386 (2.5.16-2) ...
Selecting previously unselected package libgphoto2-6:i386.
Preparing to unpack .../56-libgphoto2-6_2.5.16-2_i386.deb ...
Unpacking libgphoto2-6:i386 (2.5.16-2) ...
Selecting previously unselected package libheimbase1-heimdal:i386.
Preparing to unpack .../57-libheimbase1-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libheimbase1-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libhcrypto4-heimdal:i386.
Preparing to unpack .../58-libhcrypto4-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libhcrypto4-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libwind0-heimdal:i386.
Preparing to unpack .../59-libwind0-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libwind0-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libhx509-5-heimdal:i386.
Preparing to unpack .../60-libhx509-5-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libhx509-5-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libkrb5-26-heimdal:i386.
Preparing to unpack .../61-libkrb5-26-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libkrb5-26-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libheimntlm0-heimdal:i386.
Preparing to unpack .../62-libheimntlm0-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libheimntlm0-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libgssapi3-heimdal:i386.
Preparing to unpack .../63-libgssapi3-heimdal_7.5.0+dfsg-1_i386.deb ...
Unpacking libgssapi3-heimdal:i386 (7.5.0+dfsg-1) ...
Selecting previously unselected package libgstreamer1.0-0:i386.
Preparing to unpack .../64-libgstreamer1.0-0_1.14.1-1~ubuntu18.04.1_i386.deb ...
Unpacking libgstreamer1.0-0:i386 (1.14.1-1~ubuntu18.04.1) ...
Selecting previously unselected package liborc-0.4-0:i386.
Preparing to unpack .../65-liborc-0.4-0_1%3a0.4.28-1_i386.deb ...
Unpacking liborc-0.4-0:i386 (1:0.4.28-1) ...
Selecting previously unselected package libgstreamer-plugins-base1.0-0:i386.
Preparing to unpack .../66-libgstreamer-plugins-base1.0-0_1.14.1-1ubuntu1~ubuntu18.04.1_i386.deb ...
Unpacking libgstreamer-plugins-base1.0-0:i386 (1.14.1-1ubuntu1~ubuntu18.04.1) ...
Selecting previously unselected package liblcms2-2:i386.
Preparing to unpack .../67-liblcms2-2_2.9-1ubuntu0.1_i386.deb ...
Unpacking liblcms2-2:i386 (2.9-1ubuntu0.1) ...
Selecting previously unselected package libsasl2-modules-db:i386.
Preparing to unpack .../68-libsasl2-modules-db_2.1.27~101-g0780600+dfsg-3ubuntu2_i386.deb ...
Unpacking libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Selecting previously unselected package libsasl2-2:i386.
Preparing to unpack .../69-libsasl2-2_2.1.27~101-g0780600+dfsg-3ubuntu2_i386.deb ...
Unpacking libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Selecting previously unselected package libldap-2.4-2:i386.
Preparing to unpack .../70-libldap-2.4-2_2.4.45+dfsg-1ubuntu1.1_i386.deb ...
Unpacking libldap-2.4-2:i386 (2.4.45+dfsg-1ubuntu1.1) ...
Selecting previously unselected package libmpg123-0:i386.
Preparing to unpack .../71-libmpg123-0_1.25.10-1_i386.deb ...
Unpacking libmpg123-0:i386 (1.25.10-1) ...
Selecting previously unselected package libvorbis0a:i386.
Preparing to unpack .../72-libvorbis0a_1.3.5-4.2_i386.deb ...
Unpacking libvorbis0a:i386 (1.3.5-4.2) ...
Selecting previously unselected package libvorbisenc2:i386.
Preparing to unpack .../73-libvorbisenc2_1.3.5-4.2_i386.deb ...
Unpacking libvorbisenc2:i386 (1.3.5-4.2) ...
Selecting previously unselected package libsndfile1:i386.
Preparing to unpack .../74-libsndfile1_1.0.28-4_i386.deb ...
Unpacking libsndfile1:i386 (1.0.28-4) ...
Selecting previously unselected package libwrap0:i386.
Preparing to unpack .../75-libwrap0_7.6.q-27_i386.deb ...
Unpacking libwrap0:i386 (7.6.q-27) ...
Selecting previously unselected package libpulse0:i386.
Preparing to unpack .../76-libpulse0_1%3a11.1-1ubuntu7.1_i386.deb ...
Unpacking libpulse0:i386 (1:11.1-1ubuntu7.1) ...
Selecting previously unselected package libsndio6.1:i386.
Preparing to unpack .../77-libsndio6.1_1.1.0-3_i386.deb ...
Unpacking libsndio6.1:i386 (1.1.0-3) ...
Selecting previously unselected package libopenal1:i386.
Preparing to unpack .../78-libopenal1_1%3a1.18.2-2_i386.deb ...
Unpacking libopenal1:i386 (1:1.18.2-2) ...
Selecting previously unselected package ocl-icd-libopencl1:i386.
Preparing to unpack .../79-ocl-icd-libopencl1_2.2.11-1ubuntu1_i386.deb ...
Unpacking ocl-icd-libopencl1:i386 (2.2.11-1ubuntu1) ...
Selecting previously unselected package libwine:i386.
Preparing to unpack .../80-libwine_3.0-1ubuntu1_i386.deb ...
Unpacking libwine:i386 (3.0-1ubuntu1) ...
Selecting previously unselected package wine32:i386.
Preparing to unpack .../81-wine32_3.0-1ubuntu1_i386.deb ...
Unpacking wine32:i386 (3.0-1ubuntu1) ...
Setting up libcom-err2:i386 (1.44.1-1) ...
Setting up libtinfo5:i386 (6.1-1ubuntu1.18.04) ...
Setting up libudev1:i386 (237-3ubuntu10.9) ...
Setting up libunistring2:i386 (0.9.9-0ubuntu1) ...
Setting up libnettle6:i386 (3.4-1) ...
Setting up libexpat1:i386 (2.2.5-3) ...
Setting up libidn2-0:i386 (2.0.4-1.1build2) ...
Setting up libasyncns0:i386 (0.8-6) ...
Setting up liblcms2-2:i386 (2.9-1ubuntu0.1) ...
Setting up libjbig0:i386 (2.1-3.1build1) ...
Setting up libuuid1:i386 (2.31.1-0.4ubuntu3.2) ...
Setting up libdb5.3:i386 (5.3.28-13.1ubuntu1) ...
Setting up zlib1g:i386 (1:1.2.11.dfsg-0ubuntu2) ...
Processing triggers for libglib2.0-0:amd64 (2.56.3-0ubuntu0.18.04.1) ...
Setting up libcap2:i386 (1:2.25-1.2) ...
Setting up libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Setting up libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3ubuntu2) ...
Setting up libsystemd0:i386 (237-3ubuntu10.9) ...
Setting up libjpeg-turbo8:i386 (1.5.2-0ubuntu5.18.04.1) ...
Setting up libroken18-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libpcre3:i386 (2:8.39-9) ...
Setting up libbsd0:i386 (0.8.7-1) ...
Setting up libblkid1:i386 (2.31.1-0.4ubuntu3.2) ...
Setting up libtasn1-6:i386 (4.13-2) ...
Setting up libasound2:i386 (1.1.3-5ubuntu0.1) ...
Setting up libogg0:i386 (1.3.2-1) ...
Setting up libgmp10:i386 (2:6.1.2+dfsg-2) ...
Setting up libusb-1.0-0:i386 (2:1.0.21-2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for udev (237-3ubuntu10.9) ...
Processing triggers for doc-base (0.10.8) ...
Setting up libheimbase1-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libselinux1:i386 (2.7-2build2) ...
Setting up libltdl7:i386 (2.4.6-2) ...
Setting up libsqlite3-0:i386 (3.22.0-1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libstdc++6:i386 (8.2.0-1ubuntu2~18.04) ...
Setting up libffi6:i386 (3.2.1-8) ...
Setting up liborc-0.4-0:i386 (1:0.4.28-1) ...
Setting up libxdmcp6:i386 (1:1.1.2-3) ...
Setting up ocl-icd-libopencl1:i386 (2.2.11-1ubuntu1) ...
Setting up libmount1:i386 (2.31.1-0.4ubuntu3.2) ...
Setting up libsndio6.1:i386 (1.1.0-3) ...
Setting up libvorbis0a:i386 (1.3.5-4.2) ...
Setting up libmpg123-0:i386 (1.25.10-1) ...
Setting up libexif12:i386 (0.6.21-4) ...
Setting up libxau6:i386 (1:1.0.8-1) ...
Setting up libdbus-1-3:i386 (1.12.2-1ubuntu1) ...
Setting up libwrap0:i386 (7.6.q-27) ...
Setting up libpcap0.8:i386 (1.8.1-6ubuntu1) ...
Setting up libwebp6:i386 (0.6.1-2) ...
Setting up libjpeg8:i386 (8c-2ubuntu8) ...
Setting up libncurses5:i386 (6.1-1ubuntu1.18.04) ...
Setting up libicu60:i386 (60.2-3ubuntu3) ...
Setting up libgphoto2-port12:i386 (2.5.16-2) ...
Setting up libwind0-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libpng16-16:i386 (1.6.34-1ubuntu0.18.04.1) ...
Setting up libasn1-8-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libglib2.0-0:i386 (2.56.3-0ubuntu0.18.04.1) ...
Setting up libhcrypto4-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libflac8:i386 (1.3.2-1) ...
Setting up libtiff5:i386 (4.0.9-5) ...
Setting up libhx509-5-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libxml2:i386 (2.9.4+dfsg1-6.1ubuntu1.2) ...
Setting up libfreetype6:i386 (2.8.1-2ubuntu2) ...
Setting up libhogweed4:i386 (3.4-1) ...
Setting up libp11-kit0:i386 (0.23.9-2) ...
Setting up libopenal1:i386 (1:1.18.2-2) ...
Setting up libkrb5-26-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libvorbisenc2:i386 (1.3.5-4.2) ...
Setting up libxcb1:i386 (1.13-1) ...
Setting up libheimntlm0-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libfontconfig1:i386 (2.12.6-0ubuntu2) ...
Setting up libgstreamer1.0-0:i386 (1.14.1-1~ubuntu18.04.1) ...
Setcap worked! gst-ptp-helper is not suid!
Setting up libgnutls30:i386 (3.5.18-1ubuntu1) ...
Setting up libx11-6:i386 (2:1.6.4-3ubuntu0.1) ...
Setting up libsndfile1:i386 (1.0.28-4) ...
Setting up libxpm4:i386 (1:3.5.12-1) ...
Setting up libgssapi3-heimdal:i386 (7.5.0+dfsg-1) ...
Setting up libgstreamer-plugins-base1.0-0:i386 (1.14.1-1ubuntu1~ubuntu18.04.1) ...
Setting up libxext6:i386 (2:1.3.3-1) ...
Setting up libgd3:i386 (2.2.5-4ubuntu0.2) ...
Setting up libpulse0:i386 (1:11.1-1ubuntu7.1) ...
Setting up libldap-2.4-2:i386 (2.4.45+dfsg-1ubuntu1.1) ...
Setting up libgphoto2-6:i386 (2.5.16-2) ...
Setting up libwine:i386 (3.0-1ubuntu1) ...
Setting up wine32:i386 (3.0-1ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

=====================================================================

 

Wine
-------------------
find Ubuntu basis

sudo nano /etc/apt/sources.list
#deb cdrom:[Linux Mint 19.1 _Tessa_ - Release amd64 20181217]/ bionic contrib main non-free

-------------------
Get Wine Release Key: wget https://dl.winehq.org/wine-builds/Release.key

setup@M6500:~/Downloads$ wget https://dl.winehq.org/wine-builds/Release.key
--2018-12-23 20:42:20--  https://dl.winehq.org/wine-builds/Release.key
Resolving dl.winehq.org (dl.winehq.org)... 151.101.50.217
Connecting to dl.winehq.org (dl.winehq.org)|151.101.50.217|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3122 (3.0K) [application/pgp-keys]
Saving to: ‘Release.key’

Release.key                   100%[===============================================>]   3.05K  --.-KB/s    in 0s      

2018-12-23 20:42:20 (13.7 MB/s) - ‘Release.key’ saved [3122/3122]

-------------------
add key to keychain: sudo apt-key add Release.key

setup@M6500:~/Downloads$ sudo apt-key add Release.key
OK

-------------------
Add wine Repo To Local Repository Search
#sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'


setup@M6500:~/Downloads$ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

setup@M6500:~/Downloads$ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
setup@M6500:~/Downloads$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tessa InRelease
Hit:2 http://packages.linuxmint.com tessa Release                                                                    
Get:3 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,242 B]                                            
Hit:4 http://archive.canonical.com/ubuntu bionic InRelease                                                           
Err:3 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                      
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                          
Hit:7 http://archive.ubuntu.com/ubuntu bionic InRelease  
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]          
Get:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                    
Get:10 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:11 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.9 kB]                    
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]  
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:15 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]
Reading package lists... Done                                                
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
E: The repository 'https://dl.winehq.org/wine-builds/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

-------------------
Update the APT repo Cache
sudo apt-get update

 

-------------------

-------------------

 

 


======================================================================================
======================================================================================
======================================================================================
======================================================================================

samba config

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
Processing section "[printers]"
Processing section "[print$]"
Processing section "[shares]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions
 
# Global parameters
[global]
    dns proxy = No
    log file = /var/log/samba/log.%m
    map to guest = Bad User
    max log size = 1000
    obey pam restrictions = Yes
    pam password change = Yes
    panic action = /usr/share/samba/panic-action %d
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    passwd program = /usr/bin/passwd %u
    security = USER
    server role = standalone server
    server string = %h server (Samba, Ubuntu)
    syslog = 0
    unix password sync = Yes
    username map = /etc/samba/smbusers
    usershare allow guests = Yes
    workgroup = SILOSIX
    idmap config * : backend = tdb


[printers]
    browseable = No
    comment = All Printers
    create mask = 0700
    path = /var/spool/samba
    printable = Yes


[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers


[shares]
    guest ok = Yes
    path = /home/shares
    read only = No
silosix@M6500A:~$ findsmb

                                *=DMB
                                +=LMB
IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION
---------------------------------------------------------------------
192.168.0.203   M6500A         [    SILOSIX       ]


======================================================================================
======================================================================================
======================================================================================

 

======================================================================================
======================================================================================
JAVA8

 

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
sudo apt-get install oracle-java8-set-default
java -version

======================================================================================
silosix@M6500:~$ sudo add-apt-repository ppa:webupd8team/java
[sudo] password for silosix:             
You are about to add the following PPA:
 Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.

Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html

Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.

More info (and Ubuntu installation instructions):
- http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html

Debian installation instructions:
- Oracle Java 8: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html

For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2018/10/how-to-install-oracle-java-11-in-ubuntu.html
 More info: https://launchpad.net/~webupd8team/+archive/ubuntu/java
Press Enter to continue or Ctrl+C to cancel

Executing: /tmp/apt-key-gpghome.940atV5ukJ/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 7B2C3B0889BF5709A105D03AC2518248EEA14886
gpg: key C2518248EEA14886: 14 signatures not checked due to missing keys
gpg: key C2518248EEA14886: public key "Launchpad VLC" imported
gpg: Total number processed: 1
gpg:               imported: 1
silosix@M6500:~$ sudo apt-get update
Get:1 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,242 B]
Get:2 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease [15.4 kB]                                    
Get:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                          
Hit:4 http://archive.canonical.com/ubuntu bionic InRelease                                                
Hit:5 http://archive.ubuntu.com/ubuntu bionic InRelease                                                   
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]           
Err:1 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                      
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Ign:7 http://packages.linuxmint.com tessa InRelease                                                                  
Hit:8 http://packages.linuxmint.com tessa Release                                                                    
Get:9 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main Sources [668 B]                              
Get:10 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                                         
Get:12 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main amd64 Packages [1,556 B]                     
Get:13 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]           
Get:14 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main i386 Packages [1,556 B]
Get:15 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.9 kB]                    
Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]                           
Get:17 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main Translation-en [928 B]  
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:20 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]
Reading package lists... Done                                                
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
E: The repository 'https://dl.winehq.org/wine-builds/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
silosix@M6500:~$ sudo apt-get install oracle-java8-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  binfmt-support visualvm ttf-baekmuk | ttf-unfonts | ttf-unfonts-core ttf-kochi-gothic | ttf-sazanami-gothic
  ttf-kochi-mincho | ttf-sazanami-mincho ttf-arphic-uming
Recommended packages:
  gsfonts-x11 oracle-java8-set-default
The following NEW packages will be installed:
  oracle-java8-installer
0 upgraded, 1 newly installed, 0 to remove and 93 not upgraded.
Need to get 33.1 kB of archives.
After this operation, 118 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main amd64 oracle-java8-installer all 8u191-1~webupd8~1 [33.1 kB]
Fetched 33.1 kB in 0s (84.9 kB/s)                 
Preconfiguring packages ...
Selecting previously unselected package oracle-java8-installer.
(Reading database ... 263996 files and directories currently installed.)
Preparing to unpack .../oracle-java8-installer_8u191-1~webupd8~1_all.deb ...
Unpacking oracle-java8-installer (8u191-1~webupd8~1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint4) ...
Setting up oracle-java8-installer (8u191-1~webupd8~1) ...
No /var/cache/oracle-jdk8-installer/wgetrc file found.
Creating /var/cache/oracle-jdk8-installer/wgetrc and
using default oracle-java8-installer wgetrc settings for it.
Downloading Oracle Java 8...
--2018-12-24 03:26:57--  http://download.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz
Resolving download.oracle.com (download.oracle.com)... 172.226.108.101
Connecting to download.oracle.com (download.oracle.com)|172.226.108.101|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz [following]
--2018-12-24 03:26:57--  https://edelivery.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.207.52.180, 2600:1404:e000:299::2d3e, 2600:1404:e000:28c::2d3e
Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.207.52.180|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz?AuthParam=1545643738_ee3e4ffc2a1514bb2cd2f55ba7c738ab [following]
--2018-12-24 03:26:58--  http://download.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz?AuthParam=1545643738_ee3e4ffc2a1514bb2cd2f55ba7c738ab
Connecting to download.oracle.com (download.oracle.com)|172.226.108.101|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://download.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz?AuthParam=1545643738_ee3e4ffc2a1514bb2cd2f55ba7c738ab [following]
--2018-12-24 03:26:58--  https://download.oracle.com/otn-pub/java/jdk/8u191-b12/2787e4a523244c269598db4e85c51e0c/jdk-8u191-linux-x64.tar.gz?AuthParam=1545643738_ee3e4ffc2a1514bb2cd2f55ba7c738ab
Connecting to download.oracle.com (download.oracle.com)|172.226.108.101|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 191753373 (183M) [application/x-gzip]
Saving to: ‘jdk-8u191-linux-x64.tar.gz’

     0K ........ ........ ........ ........ ........ ........  1% 9.70M 19s
  3072K ........ ........ ........ ........ ........ ........  3% 13.8M 16s
  6144K ........ ........ ........ ........ ........ ........  4% 8.25M 17s
  9216K ........ ........ ........ ........ ........ ........  6% 14.4M 16s
 12288K ........ ........ ........ ........ ........ ........  8% 8.32M 16s
 15360K ........ ........ ........ ........ ........ ........  9% 11.5M 16s
 18432K ........ ........ ........ ........ ........ ........ 11% 7.72M 16s
 21504K ........ ........ ........ ........ ........ ........ 13% 8.93M 16s
 24576K ........ ........ ........ ........ ........ ........ 14% 5.88M 17s
 27648K ........ ........ ........ ........ ........ ........ 16% 10.3M 17s
 30720K ........ ........ ........ ........ ........ ........ 18% 6.59M 17s
 33792K ........ ........ ........ ........ ........ ........ 19% 8.12M 17s
 36864K ........ ........ ........ ........ ........ ........ 21% 5.92M 17s
 39936K ........ ........ ........ ........ ........ ........ 22% 10.4M 16s
 43008K ........ ........ ........ ........ ........ ........ 24% 6.72M 16s
 46080K ........ ........ ........ ........ ........ ........ 26% 10.0M 16s
 49152K ........ ........ ........ ........ ........ ........ 27% 6.33M 16s
 52224K ........ ........ ........ ........ ........ ........ 29% 10.1M 15s
 55296K ........ ........ ........ ........ ........ ........ 31% 5.48M 15s
 58368K ........ ........ ........ ........ ........ ........ 32% 9.27M 15s
 61440K ........ ........ ........ ........ ........ ........ 34% 6.37M 15s
 64512K ........ ........ ........ ........ ........ ........ 36% 9.87M 14s
 67584K ........ ........ ........ ........ ........ ........ 37% 6.55M 14s
 70656K ........ ........ ........ ........ ........ ........ 39% 8.68M 14s
 73728K ........ ........ ........ ........ ........ ........ 41% 5.93M 13s
 76800K ........ ........ ........ ........ ........ ........ 42% 8.34M 13s
 79872K ........ ........ ........ ........ ........ ........ 44% 6.66M 13s
 82944K ........ ........ ........ ........ ........ ........ 45% 9.60M 12s
 86016K ........ ........ ........ ........ ........ ........ 47% 7.25M 12s
 89088K ........ ........ ........ ........ ........ ........ 49% 9.35M 12s
 92160K ........ ........ ........ ........ ........ ........ 50% 6.34M 11s
 95232K ........ ........ ........ ........ ........ ........ 52% 8.42M 11s
 98304K ........ ........ ........ ........ ........ ........ 54% 6.82M 11s
101376K ........ ........ ........ ........ ........ ........ 55% 9.45M 10s
104448K ........ ........ ........ ........ ........ ........ 57% 6.81M 10s
107520K ........ ........ ........ ........ ........ ........ 59% 9.07M 9s
110592K ........ ........ ........ ........ ........ ........ 60% 6.91M 9s
113664K ........ ........ ........ ........ ........ ........ 62% 9.11M 9s
116736K ........ ........ ........ ........ ........ ........ 63% 5.84M 8s
119808K ........ ........ ........ ........ ........ ........ 65% 10.1M 8s
122880K ........ ........ ........ ........ ........ ........ 67% 5.91M 8s
125952K ........ ........ ........ ........ ........ ........ 68% 9.52M 7s
129024K ........ ........ ........ ........ ........ ........ 70% 2.49M 7s
132096K ........ ........ ........ ........ ........ ........ 72% 9.36M 7s
135168K ........ ........ ........ ........ ........ ........ 73% 5.92M 6s
138240K ........ ........ ........ ........ ........ ........ 75% 7.63M 6s
141312K ........ ........ ........ ........ ........ ........ 77% 6.10M 6s
144384K ........ ........ ........ ........ ........ ........ 78% 8.94M 5s
147456K ........ ........ ........ ........ ........ ........ 80% 6.66M 5s
150528K ........ ........ ........ ........ ........ ........ 82% 9.50M 4s
153600K ........ ........ ........ ........ ........ ........ 83% 6.78M 4s
156672K ........ ........ ........ ........ ........ ........ 85% 6.41M 4s
159744K ........ ........ ........ ........ ........ ........ 86% 6.16M 3s
162816K ........ ........ ........ ........ ........ ........ 88% 10.3M 3s
165888K ........ ........ ........ ........ ........ ........ 90% 6.18M 2s
168960K ........ ........ ........ ........ ........ ........ 91% 8.29M 2s
172032K ........ ........ ........ ........ ........ ........ 93% 5.90M 2s
175104K ........ ........ ........ ........ ........ ........ 95% 8.62M 1s
178176K ........ ........ ........ ........ ........ ........ 96% 5.18M 1s
181248K ........ ........ ........ ........ ........ ........ 98% 9.19M 0s
184320K ........ ........ ........ ........ ........ .....   100% 6.14M=25s

2018-12-24 03:27:23 (7.39 MB/s) - ‘jdk-8u191-linux-x64.tar.gz’ saved [191753373/191753373]

Download done.
Removing outdated cached downloads...
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/bin/ControlPanel to provide /usr/bin/ControlPanel (ControlPanel) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/bin/javaws to provide /usr/bin/javaws (javaws) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/bin/jcontrol to provide /usr/bin/jcontrol (jcontrol) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/bin/policytool to provide /usr/bin/policytool (policytool) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/appletviewer to provide /usr/bin/appletviewer (appletviewer) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/extcheck to provide /usr/bin/extcheck (extcheck) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/idlj to provide /usr/bin/idlj (idlj) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jar to provide /usr/bin/jar (jar) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jarsigner to provide /usr/bin/jarsigner (jarsigner) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javac to provide /usr/bin/javac (javac) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javadoc to provide /usr/bin/javadoc (javadoc) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javafxpackager to provide /usr/bin/javafxpackager (javafxpackager) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javah to provide /usr/bin/javah (javah) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javap to provide /usr/bin/javap (javap) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/javapackager to provide /usr/bin/javapackager (javapackager) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jcmd to provide /usr/bin/jcmd (jcmd) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jconsole to provide /usr/bin/jconsole (jconsole) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jdb to provide /usr/bin/jdb (jdb) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jdeps to provide /usr/bin/jdeps (jdeps) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jhat to provide /usr/bin/jhat (jhat) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jinfo to provide /usr/bin/jinfo (jinfo) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jmap to provide /usr/bin/jmap (jmap) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jmc to provide /usr/bin/jmc (jmc) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jps to provide /usr/bin/jps (jps) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jrunscript to provide /usr/bin/jrunscript (jrunscript) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jsadebugd to provide /usr/bin/jsadebugd (jsadebugd) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jstack to provide /usr/bin/jstack (jstack) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jstat to provide /usr/bin/jstat (jstat) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jstatd to provide /usr/bin/jstatd (jstatd) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/jvisualvm to provide /usr/bin/jvisualvm (jvisualvm) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/native2ascii to provide /usr/bin/native2ascii (native2ascii) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/rmic to provide /usr/bin/rmic (rmic) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/schemagen to provide /usr/bin/schemagen (schemagen) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/serialver to provide /usr/bin/serialver (serialver) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/wsgen to provide /usr/bin/wsgen (wsgen) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/wsimport to provide /usr/bin/wsimport (wsimport) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/bin/xjc to provide /usr/bin/xjc (xjc) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libnpjp2.so to provide /usr/lib/mozilla/plugins/libjavaplugin.so (mozilla-javaplugin.so) in auto mode
Oracle JDK 8 installed

#####Important########
To set Oracle JDK8 as default, install the "oracle-java8-set-default" package.
E.g.: sudo apt install oracle-java8-set-default
On Ubuntu systems, oracle-java8-set-default is most probably installed
automatically with this package.
######################

Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
silosix@M6500:~$ sudo apt-get install oracle-java8-set-default
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  oracle-java8-set-default
0 upgraded, 1 newly installed, 0 to remove and 93 not upgraded.
Need to get 6,968 B of archives.
After this operation, 20.5 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main amd64 oracle-java8-set-default all 8u191-1~webupd8~1 [6,968 B]
Fetched 6,968 B in 0s (26.8 kB/s)                    
Selecting previously unselected package oracle-java8-set-default.
(Reading database ... 264024 files and directories currently installed.)
Preparing to unpack .../oracle-java8-set-default_8u191-1~webupd8~1_all.deb ...
Unpacking oracle-java8-set-default (8u191-1~webupd8~1) ...
Setting up oracle-java8-set-default (8u191-1~webupd8~1) ...
silosix@M6500:~$ java -version
java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)

 

======================================================================================
PHP7.2 INSTALL
======================================================================================
silosix@M6500:~$ sudo apt-get install python-software-properties
[sudo] password for silosix:             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  python-software-properties
0 upgraded, 1 newly installed, 0 to remove and 93 not upgraded.
Need to get 7,392 B of archives.
After this operation, 14.3 kB of additional disk space will be used.
Get:1 http://packages.linuxmint.com tessa/upstream amd64 python-software-properties all 1.8.4 [7,392 B]
Fetched 7,392 B in 0s (23.3 kB/s)                      
Selecting previously unselected package python-software-properties.
(Reading database ... 264108 files and directories currently installed.)
Preparing to unpack .../python-software-properties_1.8.4_all.deb ...
Unpacking python-software-properties (1.8.4) ...
Setting up python-software-properties (1.8.4) ...

 


silosix@M6500:~$ sudo add-apt-repository ppa:ondrej/php
You are about to add the following PPA:
 Co-installable PHP versions: PHP 5.6, PHP 7.x and most requested extensions are included. Only Supported Versions of PHP (http://php.net/supported-versions.php) for Supported Ubuntu Releases (https://wiki.ubuntu.com/Releases) are provided. Don't ask for end-of-life PHP versions or Ubuntu release, they won't be provided.

Debian oldstable and stable packages are provided as well: https://deb.sury.org/#debian-dpa

You can get more information about the packages at https://deb.sury.org

BUGS&FEATURES: This PPA now has a issue tracker:
https://deb.sury.org/#bug-reporting

CAVEATS:
1. If you are using php-gearman, you need to add ppa:ondrej/pkg-gearman
2. If you are using apache2, you are advised to add ppa:ondrej/apache2
3. If you are using nginx, you are advise to add ppa:ondrej/nginx-mainline
   or ppa:ondrej/nginx

PLEASE READ: If you like my work and want to give me a little motivation, please consider donating regularly: https://donate.sury.org/

WARNING: add-apt-repository is broken with non-UTF-8 locales, see
https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:

# LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php
 More info: https://launchpad.net/~ondrej/+archive/ubuntu/php
Press Enter to continue or Ctrl+C to cancel

Executing: /tmp/apt-key-gpghome.52Z5CxNDhg/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 14AA40EC0831756756D7F66C4F4EA0AAE5267A6C
gpg: key 4F4EA0AAE5267A6C: public key "Launchpad PPA for Ondřej Surý" imported
gpg: Total number processed: 1
gpg:               imported: 1

 

silosix@M6500:~$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tessa InRelease
Hit:2 http://packages.linuxmint.com tessa Release                                                                    
Get:3 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,242 B]                                            
Get:4 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease [20.8 kB]                                          
Hit:5 http://archive.ubuntu.com/ubuntu bionic InRelease                                                              
Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                          
Hit:8 http://archive.canonical.com/ubuntu bionic InRelease                                                           
Get:9 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                            
Err:3 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                      
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Hit:10 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease                                             
Get:11 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]        
Get:12 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main Sources [23.8 kB]                                 
Get:13 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]                          
Get:14 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.9 kB]                    
Get:15 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 Packages [43.6 kB]              
Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]                       
Get:18 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main i386 Packages [43.6 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:20 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]
Get:21 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main Translation-en [21.5 kB]                         
Reading package lists... Done                       
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
E: The repository 'https://dl.winehq.org/wine-builds/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

 


silosix@M6500:~$ sudo apt-get install -y php7.2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  apache2-bin libapache2-mod-php7.2 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libpcre3
  libpcre3:i386 php-common php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline
Suggested packages:
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom php-pear
Recommended packages:
  apache2
The following NEW packages will be installed:
  apache2-bin libapache2-mod-php7.2 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap php-common php7.2
  php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline
The following packages will be upgraded:
  libpcre3 libpcre3:i386
2 upgraded, 13 newly installed, 0 to remove and 99 not upgraded.
Need to get 5,665 kB of archives.
After this operation, 21.7 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 libapr1 amd64 1.6.3-2 [90.9 kB]
Get:2 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main i386 libpcre3 i386 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [236 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 libaprutil1 amd64 1.6.1-2 [84.4 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 libaprutil1-dbd-sqlite3 amd64 1.6.1-2 [10.6 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 libaprutil1-ldap amd64 1.6.1-2 [8,764 B]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-bin amd64 2.4.29-1ubuntu4.5 [1,071 kB]
Get:7 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libpcre3 amd64 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [237 kB]
Get:8 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-common all 2:69+ubuntu18.04.1+deb.sury.org+1 [15.1 kB]
Get:9 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-common amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [915 kB]
Get:10 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-json amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [18.8 kB]
Get:11 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-opcache amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [165 kB]
Get:12 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-readline amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [12.2 kB]
Get:13 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-cli amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [1,405 kB]
Get:14 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libapache2-mod-php7.2 amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [1,349 kB]
Get:15 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2 all 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [45.7 kB]
Fetched 5,665 kB in 15s (370 kB/s)                                                                                   
(Reading database ... 264111 files and directories currently installed.)
Preparing to unpack .../00-libpcre3_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
De-configuring libpcre3:i386 (2:8.39-9) ...
Unpacking libpcre3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) over (2:8.39-9) ...
Preparing to unpack .../01-libpcre3_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_i386.deb ...
Unpacking libpcre3:i386 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) over (2:8.39-9) ...
Selecting previously unselected package libapr1:amd64.
Preparing to unpack .../02-libapr1_1.6.3-2_amd64.deb ...
Unpacking libapr1:amd64 (1.6.3-2) ...
Selecting previously unselected package libaprutil1:amd64.
Preparing to unpack .../03-libaprutil1_1.6.1-2_amd64.deb ...
Unpacking libaprutil1:amd64 (1.6.1-2) ...
Selecting previously unselected package libaprutil1-dbd-sqlite3:amd64.
Preparing to unpack .../04-libaprutil1-dbd-sqlite3_1.6.1-2_amd64.deb ...
Unpacking libaprutil1-dbd-sqlite3:amd64 (1.6.1-2) ...
Selecting previously unselected package libaprutil1-ldap:amd64.
Preparing to unpack .../05-libaprutil1-ldap_1.6.1-2_amd64.deb ...
Unpacking libaprutil1-ldap:amd64 (1.6.1-2) ...
Selecting previously unselected package apache2-bin.
Preparing to unpack .../06-apache2-bin_2.4.29-1ubuntu4.5_amd64.deb ...
Unpacking apache2-bin (2.4.29-1ubuntu4.5) ...
Selecting previously unselected package php-common.
Preparing to unpack .../07-php-common_2%3a69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-common (2:69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-common.
Preparing to unpack .../08-php7.2-common_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-common (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-json.
Preparing to unpack .../09-php7.2-json_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-json (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-opcache.
Preparing to unpack .../10-php7.2-opcache_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-opcache (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-readline.
Preparing to unpack .../11-php7.2-readline_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-readline (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-cli.
Preparing to unpack .../12-php7.2-cli_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-cli (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libapache2-mod-php7.2.
Preparing to unpack .../13-libapache2-mod-php7.2_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libapache2-mod-php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2.
Preparing to unpack .../14-php7.2_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libapr1:amd64 (1.6.3-2) ...
Setting up libpcre3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libpcre3:i386 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libaprutil1:amd64 (1.6.1-2) ...
Setting up php-common (2:69+ubuntu18.04.1+deb.sury.org+1) ...
Created symlink /etc/systemd/system/timers.target.wants/phpsessionclean.timer → /lib/systemd/system/phpsessionclean.timer.
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libaprutil1-ldap:amd64 (1.6.1-2) ...
Setting up php7.2-common (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/calendar.ini with new version

Creating config file /etc/php/7.2/mods-available/ctype.ini with new version

Creating config file /etc/php/7.2/mods-available/exif.ini with new version

Creating config file /etc/php/7.2/mods-available/fileinfo.ini with new version

Creating config file /etc/php/7.2/mods-available/ftp.ini with new version

Creating config file /etc/php/7.2/mods-available/gettext.ini with new version

Creating config file /etc/php/7.2/mods-available/iconv.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo.ini with new version

Creating config file /etc/php/7.2/mods-available/phar.ini with new version

Creating config file /etc/php/7.2/mods-available/posix.ini with new version

Creating config file /etc/php/7.2/mods-available/shmop.ini with new version

Creating config file /etc/php/7.2/mods-available/sockets.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvsem.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvshm.ini with new version

Creating config file /etc/php/7.2/mods-available/tokenizer.ini with new version
Setting up libaprutil1-dbd-sqlite3:amd64 (1.6.1-2) ...
Setting up apache2-bin (2.4.29-1ubuntu4.5) ...
Setting up php7.2-readline (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/readline.ini with new version
Setting up php7.2-json (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/json.ini with new version
Setting up php7.2-opcache (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/opcache.ini with new version
Setting up php7.2-cli (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in auto mode
update-alternatives: using /usr/bin/phar7.2 to provide /usr/bin/phar (phar) in auto mode
update-alternatives: using /usr/bin/phar.phar7.2 to provide /usr/bin/phar.phar (phar.phar) in auto mode

Creating config file /etc/php/7.2/cli/php.ini with new version
Setting up libapache2-mod-php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Warning: Could not load Apache 2.4 maintainer script helper.

Creating config file /etc/php/7.2/apache2/php.ini with new version
Setting up php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

 

silosix@M6500:~$ php -version
PHP 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Dec  7 2018 08:07:36) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.13-1+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

======================================================================================
INSTALLED PHP MODULES, THEN WAS OK...

 

 

 

 

silosix@M6500:/$ sudo apt-get install php-pear php-fpm php-dev php-zip php-curl php-xmlrpc php-gd php-mysql php-mbstring php-xml libapache2-mod-php
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  autoconf automake autotools-dev libc-dev-bin libc6-dev libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5
  libssl-dev libssl1.1 libtool libxmlrpc-epi0 php7.2-curl php7.2-dev php7.2-fpm php7.2-gd php7.2-mbstring
  php7.2-mysql php7.2-xml php7.2-xmlrpc php7.2-zip shtool
Suggested packages:
  autoconf-archive gnu-standards autoconf-doc glibc-doc libssl-doc libtool-doc gfortran | fortran95-compiler gcj-jdk
  dh-php
Recommended packages:
  libltdl-dev pkg-php-tools
The following NEW packages will be installed:
  autoconf automake autotools-dev libapache2-mod-php libc-dev-bin libc6-dev libpcre16-3 libpcre3-dev libpcre32-3
  libpcrecpp0v5 libssl-dev libtool libxmlrpc-epi0 php-curl php-dev php-fpm php-gd php-mbstring php-mysql php-pear
  php-xml php-xmlrpc php-zip php7.2-curl php7.2-dev php7.2-fpm php7.2-gd php7.2-mbstring php7.2-mysql php7.2-xml
  php7.2-xmlrpc php7.2-zip shtool
The following packages will be upgraded:
  libssl1.1
1 upgraded, 33 newly installed, 0 to remove and 98 not upgraded.
Need to get 11.2 MB of archives.
After this operation, 52.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 autoconf all 2.69-11 [322 kB]
Get:2 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libssl1.1 amd64 1.1.1a-2+ubuntu18.04.1+deb.sury.org+1 [1,512 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 autotools-dev all 20180224.1 [39.6 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 automake all 1:1.15.1-3ubuntu2 [509 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 libc-dev-bin amd64 2.27-3ubuntu1 [71.8 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/main amd64 libc6-dev amd64 2.27-3ubuntu1 [2,587 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main amd64 libtool all 2.4.6-2 [194 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic/main amd64 shtool all 2.0.8-9 [121 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic/main amd64 libxmlrpc-epi0 amd64 0.54.2-1.2 [30.5 kB]
Get:10 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libapache2-mod-php all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,228 B]
Get:11 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libpcre16-3 amd64 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [156 kB]
Get:12 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libpcre32-3 amd64 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [147 kB]
Get:13 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libpcrecpp0v5 amd64 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [49.9 kB]
Get:14 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libpcre3-dev amd64 2:8.41-4+ubuntu18.04.1+deb.sury.org+1 [545 kB]
Get:15 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 libssl-dev amd64 1.1.1a-2+ubuntu18.04.1+deb.sury.org+1 [1,786 kB]
Get:16 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-curl amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [28.8 kB]
Get:17 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-curl all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,072 B]
Get:18 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-dev amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [555 kB]
Get:19 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-dev all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,084 B]
Get:20 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-fpm amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [1,411 kB]
Get:21 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-fpm all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,132 B]
Get:22 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-gd amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [27.1 kB]
Get:23 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-gd all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,068 B]
Get:24 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-mbstring amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [483 kB]
Get:25 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-mbstring all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,080 B]
Get:26 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-mysql amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [117 kB]
Get:27 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-mysql all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,072 B]
Get:28 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-xml amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [107 kB]
Get:29 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-xml all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,092 B]
Get:30 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-pear all 1:1.10.6+submodules+notgz-1+ubuntu18.04.1+deb.sury.org+2 [285 kB]
Get:31 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-xmlrpc amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [12.8 kB]
Get:32 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-xmlrpc all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,076 B]
Get:33 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-zip amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [20.3 kB]
Get:34 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php-zip all 2:7.2+69+ubuntu18.04.1+deb.sury.org+1 [6,072 B]
Fetched 11.2 MB in 32s (352 kB/s)                                                                                    
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 264412 files and directories currently installed.)
Preparing to unpack .../libssl1.1_1.1.1a-2+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.1a-2+ubuntu18.04.1+deb.sury.org+1) over (1.1.0g-2ubuntu4.1) ...
Setting up libssl1.1:amd64 (1.1.1a-2+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package autoconf.
(Reading database ... 264413 files and directories currently installed.)
Preparing to unpack .../00-autoconf_2.69-11_all.deb ...
Unpacking autoconf (2.69-11) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../01-autotools-dev_20180224.1_all.deb ...
Unpacking autotools-dev (20180224.1) ...
Selecting previously unselected package automake.
Preparing to unpack .../02-automake_1%3a1.15.1-3ubuntu2_all.deb ...
Unpacking automake (1:1.15.1-3ubuntu2) ...
Selecting previously unselected package libapache2-mod-php.
Preparing to unpack .../03-libapache2-mod-php_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking libapache2-mod-php (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libc-dev-bin.
Preparing to unpack .../04-libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
Unpacking libc-dev-bin (2.27-3ubuntu1) ...
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack .../05-libc6-dev_2.27-3ubuntu1_amd64.deb ...
Unpacking libc6-dev:amd64 (2.27-3ubuntu1) ...
Selecting previously unselected package libpcre16-3:amd64.
Preparing to unpack .../06-libpcre16-3_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libpcre16-3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libpcre32-3:amd64.
Preparing to unpack .../07-libpcre32-3_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libpcre32-3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libpcrecpp0v5:amd64.
Preparing to unpack .../08-libpcrecpp0v5_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libpcrecpp0v5:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libpcre3-dev:amd64.
Preparing to unpack .../09-libpcre3-dev_2%3a8.41-4+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libpcre3-dev:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libssl-dev:amd64.
Preparing to unpack .../10-libssl-dev_1.1.1a-2+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libssl-dev:amd64 (1.1.1a-2+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package libtool.
Preparing to unpack .../11-libtool_2.4.6-2_all.deb ...
Unpacking libtool (2.4.6-2) ...
Selecting previously unselected package php7.2-curl.
Preparing to unpack .../12-php7.2-curl_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-curl (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-curl.
Preparing to unpack .../13-php-curl_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-curl (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package shtool.
Preparing to unpack .../14-shtool_2.0.8-9_all.deb ...
Unpacking shtool (2.0.8-9) ...
Selecting previously unselected package php7.2-dev.
Preparing to unpack .../15-php7.2-dev_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-dev (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-dev.
Preparing to unpack .../16-php-dev_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-dev (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-fpm.
Preparing to unpack .../17-php7.2-fpm_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-fpm (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-fpm.
Preparing to unpack .../18-php-fpm_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-fpm (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-gd.
Preparing to unpack .../19-php7.2-gd_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-gd (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-gd.
Preparing to unpack .../20-php-gd_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-gd (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-mbstring.
Preparing to unpack .../21-php7.2-mbstring_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-mbstring (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-mbstring.
Preparing to unpack .../22-php-mbstring_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-mbstring (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-mysql.
Preparing to unpack .../23-php7.2-mysql_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-mysql (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-mysql.
Preparing to unpack .../24-php-mysql_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-mysql (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-xml.
Preparing to unpack .../25-php7.2-xml_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-xml (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-xml.
Preparing to unpack .../26-php-xml_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-xml (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-pear.
Preparing to unpack .../27-php-pear_1%3a1.10.6+submodules+notgz-1+ubuntu18.04.1+deb.sury.org+2_all.deb ...
Unpacking php-pear (1:1.10.6+submodules+notgz-1+ubuntu18.04.1+deb.sury.org+2) ...
Selecting previously unselected package libxmlrpc-epi0:amd64.
Preparing to unpack .../28-libxmlrpc-epi0_0.54.2-1.2_amd64.deb ...
Unpacking libxmlrpc-epi0:amd64 (0.54.2-1.2) ...
Selecting previously unselected package php7.2-xmlrpc.
Preparing to unpack .../29-php7.2-xmlrpc_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-xmlrpc (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-xmlrpc.
Preparing to unpack .../30-php-xmlrpc_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-xmlrpc (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php7.2-zip.
Preparing to unpack .../31-php7.2-zip_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-zip (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Selecting previously unselected package php-zip.
Preparing to unpack .../32-php-zip_2%3a7.2+69+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php-zip (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.2-mysql (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.2/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo_mysql.ini with new version
Setting up php7.2-gd (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/gd.ini with new version
Setting up php7.2-xml (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/dom.ini with new version

Creating config file /etc/php/7.2/mods-available/simplexml.ini with new version

Creating config file /etc/php/7.2/mods-available/wddx.ini with new version

Creating config file /etc/php/7.2/mods-available/xml.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlreader.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlwriter.ini with new version

Creating config file /etc/php/7.2/mods-available/xsl.ini with new version
Setting up php7.2-fpm (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/fpm/php.ini with new version
Created symlink /etc/systemd/system/multi-user.target.wants/php7.2-fpm.service → /lib/systemd/system/php7.2-fpm.service.
Setting up php7.2-zip (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/zip.ini with new version
Setting up libapache2-mod-php (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Setting up php7.2-curl (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/curl.ini with new version
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up shtool (2.0.8-9) ...
Setting up libssl-dev:amd64 (1.1.1a-2+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php-curl (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up autoconf (2.69-11) ...
Setting up php-zip (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.2-mbstring (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/mbstring.ini with new version
Setting up php-xml (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libxmlrpc-epi0:amd64 (0.54.2-1.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up php-mbstring (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up autotools-dev (20180224.1) ...
Processing triggers for doc-base (0.10.8) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Setting up php-fpm (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for systemd (237-3ubuntu10.9) ...
Setting up automake (1:1.15.1-3ubuntu2) ...
update-alternatives: using /usr/bin/automake-1.15 to provide /usr/bin/automake (automake) in auto mode
Setting up php-pear (1:1.10.6+submodules+notgz-1+ubuntu18.04.1+deb.sury.org+2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libpcrecpp0v5:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libpcre32-3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libc-dev-bin (2.27-3ubuntu1) ...
Setting up libpcre16-3:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php-gd (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for libapache2-mod-php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Warning: Could not load Apache 2.4 maintainer script helper.
Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
Setting up php-mysql (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libtool (2.4.6-2) ...
Setting up php7.2-xmlrpc (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/xmlrpc.ini with new version
Setting up libpcre3-dev:amd64 (2:8.41-4+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php-xmlrpc (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.2-dev (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
update-alternatives: using /usr/bin/php-config7.2 to provide /usr/bin/php-config (php-config) in auto mode
update-alternatives: using /usr/bin/phpize7.2 to provide /usr/bin/phpize (phpize) in auto mode
Setting up php-dev (2:7.2+69+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for php7.2-fpm (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for libapache2-mod-php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Warning: Could not load Apache 2.4 maintainer script helper.
silosix@M6500:/$ cd ~/git/phpunitwebdriver/
silosix@M6500:~/git/phpunitwebdriver$ ls
bin            composer.lock       composer-setup.php       phpunit.xml  src
composer.json  composer.phar.temp  composer-setup.php.temp  README.md    tests
silosix@M6500:~/git/phpunitwebdriver$ php composer-setup.php
PHP Warning:  Failed loading Zend extension 'opcache.so' (tried: ./opcache.so (./opcache.so: cannot open shared object file: No such file or directory), ./opcache.so.so (./opcache.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'bz2' (tried: ./bz2 (./bz2: cannot open shared object file: No such file or directory), ./bz2.so (./bz2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: ./curl (./curl: cannot open shared object file: No such file or directory), ./curl.so (./curl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd2' (tried: ./gd2 (./gd2: cannot open shared object file: No such file or directory), ./gd2.so (./gd2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'mbstring' (tried: ./mbstring (./mbstring: cannot open shared object file: No such file or directory), ./mbstring.so (./mbstring.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'openssl' (tried: ./openssl (./openssl: cannot open shared object file: No such file or directory), ./openssl.so (./openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'mysqlnd.so' (tried: ./mysqlnd.so (./mysqlnd.so: cannot open shared object file: No such file or directory), ./mysqlnd.so.so (./mysqlnd.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo.so' (tried: ./pdo.so (./pdo.so: cannot open shared object file: No such file or directory), ./pdo.so.so (./pdo.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xml.so' (tried: ./xml.so (./xml.so: cannot open shared object file: No such file or directory), ./xml.so.so (./xml.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'calendar.so' (tried: ./calendar.so (./calendar.so: cannot open shared object file: No such file or directory), ./calendar.so.so (./calendar.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'ctype.so' (tried: ./ctype.so (./ctype.so: cannot open shared object file: No such file or directory), ./ctype.so.so (./ctype.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'curl.so' (tried: ./curl.so (./curl.so: cannot open shared object file: No such file or directory), ./curl.so.so (./curl.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'dom.so' (tried: ./dom.so (./dom.so: cannot open shared object file: No such file or directory), ./dom.so.so (./dom.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'exif.so' (tried: ./exif.so (./exif.so: cannot open shared object file: No such file or directory), ./exif.so.so (./exif.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'fileinfo.so' (tried: ./fileinfo.so (./fileinfo.so: cannot open shared object file: No such file or directory), ./fileinfo.so.so (./fileinfo.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'ftp.so' (tried: ./ftp.so (./ftp.so: cannot open shared object file: No such file or directory), ./ftp.so.so (./ftp.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd.so' (tried: ./gd.so (./gd.so: cannot open shared object file: No such file or directory), ./gd.so.so (./gd.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gettext.so' (tried: ./gettext.so (./gettext.so: cannot open shared object file: No such file or directory), ./gettext.so.so (./gettext.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'iconv.so' (tried: ./iconv.so (./iconv.so: cannot open shared object file: No such file or directory), ./iconv.so.so (./iconv.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'json.so' (tried: ./json.so (./json.so: cannot open shared object file: No such file or directory), ./json.so.so (./json.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'mbstring.so' (tried: ./mbstring.so (./mbstring.so: cannot open shared object file: No such file or directory), ./mbstring.so.so (./mbstring.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'mysqli.so' (tried: ./mysqli.so (./mysqli.so: cannot open shared object file: No such file or directory), ./mysqli.so.so (./mysqli.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_mysql.so' (tried: ./pdo_mysql.so (./pdo_mysql.so: cannot open shared object file: No such file or directory), ./pdo_mysql.so.so (./pdo_mysql.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'phar.so' (tried: ./phar.so (./phar.so: cannot open shared object file: No such file or directory), ./phar.so.so (./phar.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'posix.so' (tried: ./posix.so (./posix.so: cannot open shared object file: No such file or directory), ./posix.so.so (./posix.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'readline.so' (tried: ./readline.so (./readline.so: cannot open shared object file: No such file or directory), ./readline.so.so (./readline.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'shmop.so' (tried: ./shmop.so (./shmop.so: cannot open shared object file: No such file or directory), ./shmop.so.so (./shmop.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'simplexml.so' (tried: ./simplexml.so (./simplexml.so: cannot open shared object file: No such file or directory), ./simplexml.so.so (./simplexml.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sockets.so' (tried: ./sockets.so (./sockets.so: cannot open shared object file: No such file or directory), ./sockets.so.so (./sockets.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sysvmsg.so' (tried: ./sysvmsg.so (./sysvmsg.so: cannot open shared object file: No such file or directory), ./sysvmsg.so.so (./sysvmsg.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sysvsem.so' (tried: ./sysvsem.so (./sysvsem.so: cannot open shared object file: No such file or directory), ./sysvsem.so.so (./sysvsem.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'sysvshm.so' (tried: ./sysvshm.so (./sysvshm.so: cannot open shared object file: No such file or directory), ./sysvshm.so.so (./sysvshm.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'tokenizer.so' (tried: ./tokenizer.so (./tokenizer.so: cannot open shared object file: No such file or directory), ./tokenizer.so.so (./tokenizer.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'wddx.so' (tried: ./wddx.so (./wddx.so: cannot open shared object file: No such file or directory), ./wddx.so.so (./wddx.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xmlreader.so' (tried: ./xmlreader.so (./xmlreader.so: cannot open shared object file: No such file or directory), ./xmlreader.so.so (./xmlreader.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xmlrpc.so' (tried: ./xmlrpc.so (./xmlrpc.so: cannot open shared object file: No such file or directory), ./xmlrpc.so.so (./xmlrpc.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xmlwriter.so' (tried: ./xmlwriter.so (./xmlwriter.so: cannot open shared object file: No such file or directory), ./xmlwriter.so.so (./xmlwriter.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'xsl.so' (tried: ./xsl.so (./xsl.so: cannot open shared object file: No such file or directory), ./xsl.so.so (./xsl.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'zip.so' (tried: ./zip.so (./zip.so: cannot open shared object file: No such file or directory), ./zip.so.so (./zip.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The json extension is missing.
Install it or recompile php without --disable-json

The phar extension is missing.
Install it or recompile php without --disable-phar

The iconv OR mbstring extension is required and both are missing.
Install either of them or recompile php without --disable-iconv

silosix@M6500:~/git/phpunitwebdriver$ cd /
silosix@M6500:/$ sudo find -name 'opcache.so'
find: ‘./run/user/1001/gvfs’: Permission denied
./usr/lib/php/20170718/opcache.so
silosix@M6500:/$ cd /usr/lib/php
silosix@M6500:/usr/lib/php$ ls
20170718  7.2  php7.2-fpm-reopenlogs  php-helper  php-maintscript-helper  sessionclean
silosix@M6500:/usr/lib/php$ cd 7.2
silosix@M6500:/usr/lib/php/7.2$ ls
php.ini-development  php.ini-production  php.ini-production.cli  sapi
silosix@M6500:/usr/lib/php/7.2$ cd ..
silosix@M6500:/usr/lib/php$ ls
20170718  7.2  php7.2-fpm-reopenlogs  php-helper  php-maintscript-helper  sessionclean
silosix@M6500:/usr/lib/php$ cd 20170718/
silosix@M6500:/usr/lib/php/20170718$ ls
build        exif.so      iconv.so     opcache.so    readline.so   sysvsem.so    xmlrpc.so
calendar.so  fileinfo.so  json.so      pdo_mysql.so  shmop.so      sysvshm.so    xml.so
ctype.so     ftp.so       mbstring.so  pdo.so        simplexml.so  tokenizer.so  xmlwriter.so
curl.so      gd.so        mysqli.so    phar.so       sockets.so    wddx.so       xsl.so
dom.so       gettext.so   mysqlnd.so   posix.so      sysvmsg.so    xmlreader.so  zip.so
silosix@M6500:/usr/lib/php/20170718$ ^C
silosix@M6500:/usr/lib/php/20170718$ apt-cache search --names-only ^php
libapache2-mod-php7.2 - server-side, HTML-embedded scripting language (Apache 2 module)
php-common - Common files for PHP packages
php7.2 - server-side, HTML-embedded scripting language (metapackage)
php7.2-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.2-cli - command-line interpreter for the PHP scripting language
php7.2-common - documentation, examples and common module for PHP
php7.2-curl - CURL module for PHP
php7.2-dev - Files for PHP7.2 module development
php7.2-gd - GD module for PHP
php7.2-gmp - GMP module for PHP
php7.2-json - JSON module for PHP
php7.2-ldap - LDAP module for PHP
php7.2-mysql - MySQL module for PHP
php7.2-odbc - ODBC module for PHP
php7.2-opcache - Zend OpCache module for PHP
php7.2-pgsql - PostgreSQL module for PHP
php7.2-pspell - pspell module for PHP
php7.2-readline - readline module for PHP
php7.2-recode - recode module for PHP
php7.2-snmp - SNMP module for PHP
php7.2-sqlite3 - SQLite3 module for PHP
php7.2-tidy - tidy module for PHP
php7.2-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php7.2-xmlrpc - XMLRPC-EPI module for PHP
libphp7.2-embed - HTML-embedded scripting language (Embedded SAPI library)
pdepend - design quality metrics for PHP packages
php-amqp - AMQP extension for PHP
php-amqplib - pure PHP implementation of the AMQP protocol
php-analog - PHP micro logging package
php-apcu - APC User Cache for PHP
php-apcu-bc - APCu Backwards Compatibility Module
php-apigen-theme-bootstrap - Twitter Bootstrap theme for ApiGen
php-apigen-theme-default - Default theme for ApiGen
php-ast - AST extension for PHP 7
php-auth-sasl - Abstraction of various SASL mechanism responses
php-cache-integration-tests - Integration tests for PSR-6 and PSR-16 cache implementations
php-cache-lite - Fast and Safe little cache system
php-cache-tag-interop - Framework interoperable interfaces for tags
php-cas - Central Authentication Service client library in php
php-cassandra - DataStax PHP Driver for Apache Cassandra
php-cli-prompt - tiny helper prompting for user input
php-codecoverage - collection, processing, and rendering for code coverage
php-codesniffer - PHP, CSS and JavaScript coding standard analyzer and checker
php-composer-ca-bundle - utility library to find a path to the system CA bundle
php-composer-semver - utilities, version constraint parsing and validation
php-composer-spdx-licenses - SPDX licenses list and validation library
php-console-commandline - A full featured command line options and arguments parser
php-console-table - Library that makes it easy to build console style tables
php-constant-time - Constant-time Implementations of RFC 4648 Encoding (Base-64, Base-32, Base-16)
php-date - Generic date/time handling class for PEAR
php-db - Database Abstraction Layer
php-db-dataobject - PHP PEAR module for object based SQL query building
php-deepcopy - create deep copies (clones) of objects
php-directory-scanner - recursive directory scanner and filter
php-doctrine-annotations - Docblock Annotations Parser - Doctrine component
php-doctrine-bundle - bundle library - Doctrine component
php-doctrine-cache - cache library - Doctrine component
php-doctrine-cache-bundle - cache bundle library - Doctrine component
php-doctrine-collections - Collections Abstraction library - Doctrine component
php-doctrine-common - common extensions for Doctrine
php-doctrine-data-fixtures - Data Fixtures for all Doctrine Object Managers
php-doctrine-dbal - database abstraction layer for Doctrine
php-doctrine-inflector - string manipulations library - Doctrine component
php-doctrine-instantiator - lightweight utility to instantiate objects in PHP
php-doctrine-lexer - base lexer library - Doctrine component
php-doctrine-orm - tool for object-relational mapping
php-dompdf - HTML to PDF converter
php-ds - PHP extension providing efficient data structures for PHP 7
php-elisp - Emacs support for php files
php-email-validator - A library for validating emails against several RFCs
php-enum - Simple and fast implementation of enumerations with native PHP>=5.6
php-facedetect - Detect faces with PHP
php-fdomdocument - extension to PHP's standard DOM
php-fig-link-util - Common utility implementations for HTTP links
php-file-iterator - FilterIterator implementation for PHP
php-finder-facade - convenience wrapper for Symfony's Finder component
php-finder-facade-doc - convenience wrapper for Symfony's Finder component - documentation
php-font-lib - read, parse, export and make subsets of different fonts
php-fpdf - PHP class to generate PDF files
php-fshl - Fast Syntax HighLighter
php-fxsl - XSL wrapper and extension to XSLTProcessor
php-gearman - PHP wrapper to libgearman
php-geoip - GeoIP module for PHP
php-geos - GEOS bindings for PHP
php-geshi - Generic Syntax Highlighter
php-getid3 - scripts to extract information from multimedia files
php-gettext - transitional dummy package for php-php-gettext
php-gmagick - Provides a wrapper to the GraphicsMagick library
php-gnupg - PHP wrapper around the gpgme library
php-guestfs - guest disk image management system - PHP bindings
php-guzzlehttp-promises - Guzzle promises library
php-hamcrest - This is the PHP port of Hamcrest Matchers
php-horde - Horde Application Framework
php-horde-activesync - ActiveSync server library
php-horde-alarm - Horde Alarm Libraries
php-horde-ansel - Photo management application
php-horde-argv - Horde command-line argument parsing package
php-horde-auth - Horde Authentication API
php-horde-autoloader - Horde Autoloader
php-horde-browser - Horde Browser API
php-horde-cache - Horde Caching API
php-horde-cli - Horde Command Line Interface API
php-horde-compress - Horde Compression API
php-horde-compress-fast - Fast Compression Library
php-horde-constraint - Horde Constraint library
php-horde-content - Tagging application
php-horde-controller - Horde Controller libraries
php-horde-core - Core Horde Framework library
php-horde-crypt - Horde Cryptography API
php-horde-crypt-blowfish - Blowfish Encryption Library
php-horde-css-parser - Horde CSS Parser
php-horde-cssminify - CSS Minification
php-horde-data - Horde Data API
php-horde-date - Horde Date package
php-horde-date-parser - Horde Date Parser
php-horde-dav - Horde library for WebDAV, CalDAV, CardDAV
php-horde-db - Horde Database Libraries
php-horde-editor - Horde Editor API
php-horde-elasticsearch - Horde ElasticSearch client
php-horde-exception - Horde Exception Handler
php-horde-feed - Horde Feed libraries
php-horde-form - Horde Form API
php-horde-gollem - Web-based file manager
php-horde-group - Horde User Groups System
php-horde-groupware - Horde Groupware
php-horde-hashtable - Horde Hash Table Interface
php-horde-history - API for tracking the history of an object
php-horde-http - Horde HTTP libraries
php-horde-icalendar - iCalendar API
php-horde-idna - IDNA backend normalization package
php-horde-image - Horde Image API
php-horde-imap-client - Horde IMAP Client
php-horde-imp - A web based webmail system
php-horde-imsp - IMSP API
php-horde-ingo - An email filter rules manager
php-horde-injector - Horde dependency injection container
php-horde-itip - iTip invitation response handling
php-horde-javascriptminify - Javascript Minification
php-horde-kolab-format - A package for reading/writing Kolab data formats
php-horde-kolab-server - A package for manipulating the Kolab user database
php-horde-kolab-session - A package managing an active Kolab session
php-horde-kolab-storage - A package for handling Kolab data stored on an IMAP server
php-horde-kronolith - A web based calendar
php-horde-ldap - Horde LDAP libraries
php-horde-listheaders - Horde List Headers Parsing Library
php-horde-lock - Horde Resource Locking System
php-horde-log - Horde Logging library
php-horde-logintasks - Horde Login Tasks System
php-horde-lz4 - Horde LZ4 Compression Extension
php-horde-mail - Horde Mail Library
php-horde-mail-autoconfig - Horde Mail Autoconfiguration
php-horde-mapi - MAPI utility library
php-horde-memcache - Horde Memcache API
php-horde-mime - Horde MIME Library
php-horde-mime-viewer - Horde MIME Viewer Library
php-horde-mnemo - A web based notes manager
php-horde-mongo - Horde Mongo Configuration
php-horde-nag - A web based task list manager
php-horde-nls - Native Language Support (NLS)
php-horde-notification - Horde Notification System
php-horde-oauth - Horde OAuth client/server
php-horde-openxchange - Open-Xchange Connector
php-horde-pack - Horde Pack Utility
php-horde-passwd - Horde password changing application
php-horde-pdf - Horde PDF library
php-horde-perms - Horde Permissions System
php-horde-prefs - Horde Preferences API
php-horde-queue - Horde Queue
php-horde-rdo - Rampage Data Objects
php-horde-role - PEAR installer role used to install Horde components
php-horde-routes - Horde Routes URL mapping system
php-horde-rpc - Horde RPC API
php-horde-scheduler - Horde Scheduler System
php-horde-scribe - Scribe
php-horde-secret - Secret Encryption API
php-horde-serialize - Data Encapulation API
php-horde-service-facebook - Horde Facebook client
php-horde-service-gravatar - API accessor for gravatar.com
php-horde-service-twitter - Horde Twitter client
php-horde-service-urlshortener - Horde_Service_UrlShortener Class
php-horde-service-weather - Horde Weather Provider
php-horde-sesha - A simple Inventory App for Horde
php-horde-sessionhandler - Horde Session Handler API
php-horde-share - Horde Shared Permissions System
php-horde-smtp - Horde SMTP Client
php-horde-socket-client - Horde Socket Client
php-horde-spellchecker - Spellcheck API
php-horde-stream - Horde stream handler
php-horde-stream-filter - Horde Stream filters
php-horde-stream-wrapper - PHP stream wrappers library
php-horde-support - Horde support package
php-horde-syncml - Horde_SyncMl provides an API for processing SyncML requests
php-horde-template - Horde Template System
php-horde-test - Horde testing base classes
php-horde-text-diff - Engine for performing and rendering text diffs
php-horde-text-filter - Horde Text Filter API
php-horde-text-flowed - Horde API for flowed text as per RFC 3676
php-horde-thrift - Thrift
php-horde-timeobjects - Horde timeobjects application
php-horde-timezone - Timezone library
php-horde-token - Horde Token API
php-horde-translation - Horde translation library
php-horde-trean - Web-based bookmarks application
php-horde-tree - Horde Tree API
php-horde-turba - A web based address book
php-horde-url - Horde Url class
php-horde-util - Horde Utility Libraries
php-horde-vfs - Virtual File System API
php-horde-view - Horde View API
php-horde-webmail - Horde Groupware Webmail Edition
php-horde-whups - Ticket-tracking application
php-horde-wicked - Wiki application
php-horde-xml-element - Horde Xml Element object
php-horde-xml-wbxml - Horde_Xml_Wbxml provides an API for encoding and decoding WBXML documents used in SyncML and other wireless applications
php-html-safe - strip down all potentially dangerous content within HTML
php-htmlawed - htmLawed PHP code to purify & filter HTML
php-htmlpurifier - Standards-compliant HTML filter
php-http - PECL HTTP module for PHP Extended HTTP Support
php-http-request - Provides an easy way to perform HTTP requests
php-http-request2 - Provides an easy way to perform HTTP requests
php-http-webdav-server - WebDAV Server Baseclass
php-icinga - PHP library to communicate with and use Icinga
php-igbinary - igbinary PHP serializer
php-image-text - Image_Text - Advanced text maipulations in images
php-imagick - Provides a wrapper to the ImageMagick library
php-invoker - Utility class for invoking callables with a timeout
php-jmespath - Declaratively specify how to extract elements from a JSON document
php-json-schema - implementation of JSON schema
php-kdyby-events - Events for Nette Framework
php-klogger - simple logging class
php-letodms-core - Document management system
php-letodms-lucene - Document management system - Fulltext search
php-libsodium - PHP wrapper for the Sodium cryptographic library
php-libvirt-php - libvirt bindings for PHP
php-log - Logging Framework
php-luasandbox - PHP extension that provides a sandboxed Lua environment
php-mail - Class that provides multiple interfaces for sending emails
php-mail-mime - PHP PEAR module for creating MIME messages
php-mailparse - Email message manipulation for PHP
php-mapi - Complete and feature rich groupware solution - PHP MAPI bindings
php-markdown - PHP library for rendering Markdown data
php-mdb2 - database abstraction layer
php-mdb2-driver-mysql - mysql MDB2 driver
php-mdb2-driver-pgsql - pgsql MDB2 driver
php-memcache - memcache extension module for PHP
php-memcached - memcached extension module for PHP, uses libmemcached
php-mf2 - Microformats2 is the simplest way to markup structured information in HTML
php-mime-type - Utility class for dealing with MIME types
php-mockery - mock object framework for PHPUnit and other testing framework
php-mockery-doc - mock object framework for PHPUnit - documentation
php-mongodb - MongoDB driver for PHP
php-monolog - send logs to various destination and web services
php-msgpack - PHP extension for interfacing with MessagePack
php-net-dime - The Net_DIME package implements DIME encoding and decoding
php-net-dns2 - PHP5 Resolver library used to communicate with a DNS server
php-net-ftp - Net_FTP provides an OO interface to the PHP FTP functions plus some additions
php-net-idna2 - PHP Pear module for handling international domain names
php-net-imap - Provides an implementation of the IMAP protocol
php-net-ipv6 - Check and validate IPv6 addresses
php-net-ldap2 - Object oriented interface for searching and manipulating LDAP-entries
php-net-ldap3 - Object oriented interface for searching and manipulating LDAP entries
php-net-nntp - NNTP implementation
php-net-publicsuffix - PHP module for detecting registered domains and public suffixes
php-net-sieve - Handles talking to a sieve server
php-net-smtp - PHP PEAR module implementing SMTP protocol
php-net-socket - Network Socket Interface
php-net-url - Easy parsing of Urls
php-net-url2 - Class for parsing and handling URL
php-net-whois - PHP PEAR module for querying whois services
php-nette - Nette Framework
php-nrk-predis - Flexible and feature-complete PHP client library for the Redis key-value store
php-numbers-words - PEAR module providing methods for spelling numerals in words
php-oauth - OAuth 1.0 consumer and provider extension
php-parser - convert PHP code into abstract syntax tree
php-patchwork-utf8 - UTF-8 strings handling for PHP
php-pclzip - ZIP archive manager class for PHP
php-pecl-http - pecl_http module for PHP Extended HTTP Support [dummy]
php-pecl-http-dev - pecl_http module for PHP Extended HTTP Support [dummy]
php-phar-io-manifest - reading phar.io manifest information from a PHP Archive (Phar)
php-phar-io-version - handling version information and constraint
php-php-gettext - read gettext MO files directly, without requiring anything other than PHP
php-phpdocumentor-reflection-common - Common reflection classes - phpDocumentor component
php-phpdocumentor-reflection-docblock - DocBlock parser - phpDocumentor component
php-phpdocumentor-type-resolver - TypeResolver and FqsenResolver - phpDocumentor component
php-phpseclib - implementations of an arbitrary-precision integer arithmetic library
php-phpspec-prophecy - object mocking framework - phpspec component
php-pimple - simple dependency injection container -- class
php-pinba - Pinba module for PHP
php-propro - propro module for PHP
php-propro-dev - propro module for PHP development headers [dummy]
php-proxy-manager - library providing utilities to operate with Object Proxies
php-ps - ps module for PHP
php-psr-cache - Common interface for caching libraries
php-psr-container - Common Container Interface (PHP FIG PSR-11)
php-psr-http-message - Common interface for HTTP messages
php-psr-link - Common interfaces for HTTP links
php-psr-log - common interface for logging libraries
php-psr-simple-cache - Common interfaces for simple caching
php-radius - radius client library for PHP
php-random-compat - PHP 5.x polyfill for random_bytes() and random_int() from PHP 7
php-raphf - raphf module for PHP
php-raphf-dev - raphf module for PHP development headers [dummy]
php-react-promise - lightweight implementation of CommonJS Promises/A for PHP
php-redis - PHP extension for interfacing with Redis
php-remctl - PECL module for Kerberos-authenticated command execution
php-rrd - PHP bindings to rrd tool system
php-sabre-dav - WebDAV Framework for PHP
php-sabre-vobject - library to parse and manipulate iCalendar and vCard objects
php-sass - PHP bindings to libsass - fast, native Sass parsing in PHP
php-seclib - implementations of an arbitrary-precision integer arithmetic library
php-services-json - PHP implementaion of json_encode/decode
php-services-weather - This class acts as an interface to various online weather-services
php-smbclient - PHP wrapper for libsmbclient
php-solr - PHP extension for communicating with Apache Solr server
php-sql-formatter - a PHP SQL highlighting library
php-ssh2 - Bindings for the libssh2 library
php-stomp - Streaming Text Oriented Messaging Protocol (STOMP) client module for PHP
php-swiftmailer - Swiftmailer, free feature-rich PHP mailer
php-symfony - set of reusable components and framework for web projects
php-symfony-asset - manage asset URLs
php-symfony-browser-kit - simulate the behavior of a web browser
php-symfony-cache - Symfony Cache component with PSR-6, PSR-16, and tags
php-symfony-class-loader - load PHP classes automatically
php-symfony-config - load configurations from different data sources
php-symfony-console - run tasks from the command line
php-symfony-css-selector - convert CSS selectors to XPath expressions
php-symfony-debug - tools to make debugging of PHP code easier
php-symfony-debug-bundle - debugging tools for the Symfony framework
php-symfony-dependency-injection - standardize and centralize construction of objects
php-symfony-doctrine-bridge - integration for Doctrine with Symfony Components
php-symfony-dom-crawler - ease DOM navigation for HTML and XML documents
php-symfony-dotenv - .env files parser to make environment variables accessible
php-symfony-event-dispatcher - dispatch events and listen to them
php-symfony-expression-language - compile and evaluate expressions
php-symfony-filesystem - basic filesystem utilities
php-symfony-finder - find files and directories
php-symfony-form - create HTML forms and process request data
php-symfony-framework-bundle - basic, robust and flexible MVC framework
php-symfony-http-foundation - object-oriented layer for the HTTP specification
php-symfony-http-kernel - building blocks for flexible and fast HTTP-based frameworks
php-symfony-inflector - words conversion between their singular and plural forms
php-symfony-intl - limited replacement layer for the PHP extension intl
php-symfony-ldap - abstraction layer for the PHP LDAP module
php-symfony-lock - creates and manages locks
php-symfony-monolog-bridge - integration for Monolog with Symfony Components
php-symfony-options-resolver - configure objects with option arrays
php-symfony-phpunit-bridge - integration for PHPUnit with Symfony Components
php-symfony-polyfill - Symfony polyfills backporting features to lower PHP versions
php-symfony-polyfill-apcu - Symfony polyfill backporting apcu_* functions to lower PHP versions
php-symfony-polyfill-iconv - Symfony polyfill for the Iconv extension
php-symfony-polyfill-intl-grapheme - Symfony polyfill for intl's grapheme_* functions
php-symfony-polyfill-intl-icu - Symfony polyfill for intl's ICU-related data and classes
php-symfony-polyfill-intl-normalizer - Symfony polyfill for intl's Normalizer class and related functions
php-symfony-polyfill-mbstring - Symfony polyfill for the Mbstring extension
php-symfony-polyfill-php54 - Symfony polyfill backporting some PHP 5.4+ features to lower PHP versions
php-symfony-polyfill-php55 - Symfony polyfill backporting some PHP 5.5+ features to lower PHP versions
php-symfony-polyfill-php56 - Symfony polyfill backporting some PHP 5.6+ features to lower PHP versions
php-symfony-polyfill-php70 - Symfony polyfill backporting some PHP 7.0+ features to lower PHP versions
php-symfony-polyfill-php71 - Symfony polyfill backporting some PHP 7.1+ features to lower PHP versions
php-symfony-polyfill-php72 - Symfony polyfill backporting some PHP 7.2+ features to lower PHP versions
php-symfony-polyfill-util - Symfony utilities for portability of PHP codes
php-symfony-polyfill-xml - Symfony polyfill for xml's utf8_encode and utf8_decode functions
php-symfony-process - execute commands in sub-processes
php-symfony-property-access - read from and write to an object or array
php-symfony-property-info - extract information about properties of PHP classes
php-symfony-proxy-manager-bridge - integration for ProxyManager with Symfony Components
php-symfony-routing - associate a request with code that generates a response
php-symfony-security - infrastructure for sophisticated authorization systems
php-symfony-security-acl - Symfony Security Component - ACL (Access Control List)
php-symfony-security-bundle - configurable security system for the Symfony framework
php-symfony-security-core - infrastructure for authorization systems - common features
php-symfony-security-csrf - infrastructure for authorization systems - CSRF protection
php-symfony-security-guard - infrastructure for authorization systems - Guard features
php-symfony-security-http - infrastructure for authorization systems - HTTP integration
php-symfony-serializer - convert PHP objects into specific formats and vice versa
php-symfony-stopwatch - profile PHP code
php-symfony-templating - tools needed to build a template system
php-symfony-translation - tools to internationalize an application
php-symfony-twig-bridge - integration for Twig with Symfony Components
php-symfony-twig-bundle - configurable integration of Twig with the Symfony framework
php-symfony-validator - tools to validate classes
php-symfony-var-dumper - Symfony mechanism for exploring and dumping PHP variables
php-symfony-web-link - manage links between resources
php-symfony-web-profiler-bundle - collect requests information for analysis and debugging
php-symfony-web-server-bundle - provide commands for applications using the PHP built-in web server
php-symfony-workflow - manage a workflow or finite state machine
php-symfony-yaml - convert YAML to PHP arrays and the other way around
php-tcpdf - PHP class for generating PDF files on-the-fly
php-text-captcha - Generation of CAPTCHAs
php-text-figlet - Engine for use FIGlet fonts to rendering text
php-text-languagedetect - Language detection class
php-text-password - Creating passwords with PHP
php-text-template - Simple template engine
php-text-wiki - transform Wiki and BBCode markup into XHTML, LaTeX or plain text markup
php-tideways - Tideways PHP Profiler Extension
php-timer - Utility class for timing
php-token-stream - Wrapper around PHP's tokenizer extension
php-tokenizer - tokenized PHP source to XML converter
php-tokenreflection - PHP reflection replacement
php-twig - Flexible, fast, and secure template engine for PHP
php-twig-doc - Twig template engine documentation
php-uploadprogress - file upload progress tracking extension for PHP
php-uuid - PHP UUID extension
php-validate - validation class
php-webmozart-assert - Assertions to validate method input/output with nice error messages
php-wikidiff2 - external diff engine for mediawiki
php-xajax - A library to develop Ajax applications
php-xml-htmlsax3 - SAX parser for HTML and other badly formed XML documents
php-xml-rpc2 - PHP XML-RPC client/server library
php-xml-svg - XML_SVG API
php-yac - YAC (Yet Another Cache) for PHP
php-yaml - YAML-1.1 parser and emitter for PHP
php-zend-code - Zend Framework - Code component
php-zend-db - Zend Framework - Db component
php-zend-eventmanager - Zend Framework - EventManager component
php-zend-hydrator - Zend Framework - Hydrator component
php-zend-stdlib - Zend Framework - Stdlib component
php-zeroc-ice - PHP extension for Ice
php-zeta-base - Zeta Components - Base package
php-zeta-console-tools - Zeta Components - ConsoleTools package
php-zeta-unit-test - Zeta Components - UnitTest package
php-zmq - ZeroMQ messaging bindings for PHP
php7.1-mapi - transitional package for the rename of php7.1-mapi to php-mapi
php7.2-bcmath - Bcmath module for PHP
php7.2-bz2 - bzip2 module for PHP
php7.2-dba - DBA module for PHP
php7.2-enchant - Enchant module for PHP
php7.2-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php7.2-imap - IMAP module for PHP
php7.2-interbase - Interbase module for PHP
php7.2-intl - Internationalisation module for PHP
php7.2-mbstring - MBSTRING module for PHP
php7.2-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php7.2-soap - SOAP module for PHP
php7.2-sybase - Sybase module for PHP
php7.2-xsl - XSL module for PHP (dummy)
php7.2-zip - Zip module for PHP
php7cc - command line tool to detect PHP 7 incompatible code
phpab - lightweight PHP namespace aware autoload generator
phpcpd - copy and paste detector (CPD) for PHP code
phpdox - documentation generation framework and tool
phpldapadmin - web based interface for administering LDAP servers
phpliteadmin - web-based SQLite database admin tool
phpliteadmin-themes - web-based SQLite database admin tool - themes
phploc - tool for quickly measuring the size of a PHP project
phpmd - PHP Mess Detector
phpmyadmin - MySQL web administration tool
phppgadmin - web-based administration tool for PostgreSQL
phpqrcode - PHP library for generating two-dimensional barcodes
phpsysinfo - PHP based host information
phpunit - Unit testing suite for PHP
phpunit-code-unit-reverse-lookup - look up what a line of code belongs to - PHPUnit component
phpunit-comparator - functionality to compare PHP values for equality - PHPUnit component
phpunit-dbunit - PHPUnit extension for database interaction testing
phpunit-diff - diff implementation - stand-alone component from PHPUnit
phpunit-environment - functionality to handle HHVM/PHP environments - PHPUnit component
phpunit-exporter - export variables for visualization - PHPUnit component
phpunit-git - Simple wrapper for Git
phpunit-global-state - snapshotting of global state - PHPUnit component
phpunit-mock-object - Mock Object library for PHPUnit
phpunit-object-enumerator - enumerate all referenced objects - PHPUnit component
phpunit-object-reflector - reflection of object attributes - PHPUnit component
phpunit-recursion-context - recursively process PHP variables - PHPUnit component
phpunit-resource-operations - provide a list of PHP built-in functions that operate on resources
phpunit-version - Library that helps with managing the version number of Git-hosted PHP projects
phpwebcounter - simple and light web hit counter
phpwebcounter-extra - extra graphical numbers to PHP Web Counter
uwsgi-plugin-php - PHP plugin for uWSGI
php-horde-javascriptminify-jsmin - Horde Javascript Minifier - Jsmin PHP Driver
php-horde-text-filter-jsmin - Horde Text Filter - Jsmin PHP Driver
php-mythtv - PHP Bindings for MythTV
php-pear - PEAR Base System
php-soap - SOAP module for PHP [default]
php-sqlite3 - SQLite3 module for PHP [default]
php - server-side, HTML-embedded scripting language (default)
php7.0-common - documentation, examples and common module for PHP
libapache2-mod-php7.0 - server-side, HTML-embedded scripting language (Apache 2 module)
php7.0-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.0-cli - command-line interpreter for the PHP scripting language
php7.0-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php7.0-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
libphp7.0-embed - HTML-embedded scripting language (Embedded SAPI library)
php7.0-dev - Files for PHP7.0 module development
php7.0-curl - CURL module for PHP
php7.0-enchant - Enchant module for PHP
php7.0-gd - GD module for PHP
php7.0-gmp - GMP module for PHP
php7.0-imap - IMAP module for PHP
php7.0-interbase - Interbase module for PHP
php7.0-intl - Internationalisation module for PHP
php7.0-ldap - LDAP module for PHP
php7.0-mcrypt - libmcrypt module for PHP
php7.0-readline - readline module for PHP
php7.0-odbc - ODBC module for PHP
php7.0-pgsql - PostgreSQL module for PHP
php7.0-pspell - pspell module for PHP
php7.0-recode - recode module for PHP
php7.0-snmp - SNMP module for PHP
php7.0-tidy - tidy module for PHP
php7.0-xmlrpc - XMLRPC-EPI module for PHP
php7.0-xsl - XSL module for PHP (dummy)
php7.0 - server-side, HTML-embedded scripting language (metapackage)
php7.0-json - JSON module for PHP
php-cgi - server-side, HTML-embedded scripting language (CGI binary) (default)
php-cli - command-line interpreter for the PHP scripting language (default)
php-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary) (default)
php-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary) (default)
php-dev - Files for PHP module development (default)
php-all-dev - package depending on all supported PHP development packages
php7.0-sybase - Sybase module for PHP
php-bcmath - Bcmath module for PHP [default]
php-curl - CURL module for PHP [default]
php-enchant - Enchant module for PHP [default]
php-gd - GD module for PHP [default]
php-gmp - GMP module for PHP [default]
php-imap - IMAP module for PHP [default]
php-interbase - Interbase module for PHP [default]
php-intl - Internationalisation module for PHP [default]
php-json - JSON module for PHP [default]
php-ldap - LDAP module for PHP [default]
php-mbstring - MBSTRING module for PHP [default]
php-mysql - MySQL module for PHP [default]
php-pgsql - PostgreSQL module for PHP [default]
php-pspell - pspell module for PHP [default]
php-readline - readline module for PHP [default]
php-recode - recode module for PHP [default]
php-snmp - SNMP module for PHP [default]
php-sybase - Sybase module for PHP [default]
php-tidy - tidy module for PHP [default]
php-xmlrpc - XMLRPC-EPI module for PHP [default]
php-zip - Zip module for PHP [default]
libapache2-mod-php5.6 - server-side, HTML-embedded scripting language (Apache 2 module)
php5.6-cgi - server-side, HTML-embedded scripting language (CGI binary)
php5.6-cli - command-line interpreter for the PHP scripting language
php5.6-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php5.6-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
libphp5.6-embed - HTML-embedded scripting language (Embedded SAPI library)
php5.6-dev - Files for PHP5.6 module development
php5.6-common - documentation, examples and common module for PHP
php5.6 - server-side, HTML-embedded scripting language (metapackage)
php7.0-sqlite3 - SQLite3 module for PHP
php7.0-mysql - MySQL module for PHP
php7.0-opcache - Zend OpCache module for PHP
php5.6-curl - CURL module for PHP
php5.6-gd - GD module for PHP
php5.6-imap - IMAP module for PHP
php5.6-intl - Internationalisation module for PHP
php5.6-ldap - LDAP module for PHP
php5.6-mysql - MySQL module for PHP
php5.6-pgsql - PostgreSQL module for PHP
php5.6-pspell - pspell module for PHP
php5.6-recode - recode module for PHP
php5.6-snmp - SNMP module for PHP
php5.6-sqlite3 - SQLite3 module for PHP
php5.6-sybase - Sybase module for PHP
php5.6-tidy - tidy module for PHP
php5.6-opcache - Zend OpCache module for PHP
php-xdebug - Xdebug Module for PHP
php5.6-json - JSON module for PHP
php7.0-bz2 - bzip2 module for PHP
php5.6-bz2 - bzip2 module for PHP
php5.6-mcrypt - libmcrypt module for PHP
php5.6-odbc - ODBC module for PHP
php5.6-readline - readline module for PHP
php-bz2 - bzip2 module for PHP [default]
php-odbc - ODBC module for PHP [default]
php5.6-interbase - Interbase module for PHP
php5.6-xmlrpc - XMLRPC-EPI module for PHP
php5.6-enchant - Enchant module for PHP
php5.6-gmp - GMP module for PHP
php5.6-xsl - XSL module for PHP (dummy)
php5.6-bcmath - Bcmath module for PHP
php5.6-mbstring - MBSTRING module for PHP
php5.6-soap - SOAP module for PHP
php5.6-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php5.6-zip - Zip module for PHP
php7.0-bcmath - Bcmath module for PHP
php7.0-mbstring - MBSTRING module for PHP
php7.0-soap - SOAP module for PHP
php7.0-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php7.0-zip - Zip module for PHP
php-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
php-xcache - fast, stable PHP opcode cacher
php-mongo - MongoDB database driver
php5.6-dba - DBA module for PHP
php7.0-dba - DBA module for PHP
php-xhprof - Hierarchical Profiler for PHP 5.x
php-mysqlnd-ms - MySQL replication and load balancing module for PHP
libapache2-mod-php7.1 - server-side, HTML-embedded scripting language (Apache 2 module)
libphp7.1-embed - HTML-embedded scripting language (Embedded SAPI library)
php7.1-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.1-cli - command-line interpreter for the PHP scripting language
php7.1-dev - Files for PHP7.1 module development
php7.1-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php7.1-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php7.1-bcmath - Bcmath module for PHP
php7.1-bz2 - bzip2 module for PHP
php7.1-common - documentation, examples and common module for PHP
php7.1-curl - CURL module for PHP
php7.1-dba - DBA module for PHP
php7.1-enchant - Enchant module for PHP
php7.1-gd - GD module for PHP
php7.1-gmp - GMP module for PHP
php7.1-imap - IMAP module for PHP
php7.1-interbase - Interbase module for PHP
php7.1-intl - Internationalisation module for PHP
php7.1-json - JSON module for PHP
php7.1-ldap - LDAP module for PHP
php7.1-mbstring - MBSTRING module for PHP
php7.1-mcrypt - libmcrypt module for PHP
php7.1-mysql - MySQL module for PHP
php7.1-odbc - ODBC module for PHP
php7.1-pgsql - PostgreSQL module for PHP
php7.1-pspell - pspell module for PHP
php7.1-readline - readline module for PHP
php7.1-recode - recode module for PHP
php7.1-snmp - SNMP module for PHP
php7.1-soap - SOAP module for PHP
php7.1-sqlite3 - SQLite3 module for PHP
php7.1-sybase - Sybase module for PHP
php7.1-tidy - tidy module for PHP
php7.1-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php7.1-xmlrpc - XMLRPC-EPI module for PHP
php7.1-zip - Zip module for PHP
php7.1-opcache - Zend OpCache module for PHP
php7.1 - server-side, HTML-embedded scripting language (metapackage)
php7.1-xsl - XSL module for PHP (dummy)
php-phalcon - full-stack PHP framework delivered as a C-extension
php-lua - PHP Embedded lua interpreter
php-sodium - PHP wrapper for the Sodium cryptographic library
libapache2-mod-php7.3 - server-side, HTML-embedded scripting language (Apache 2 module)
libphp7.3-embed - HTML-embedded scripting language (Embedded SAPI library)
php7.3-bcmath - Bcmath module for PHP
php7.3-bz2 - bzip2 module for PHP
php7.3-cgi - server-side, HTML-embedded scripting language (CGI binary)
php7.3-cli - command-line interpreter for the PHP scripting language
php7.3-common - documentation, examples and common module for PHP
php7.3-curl - CURL module for PHP
php7.3-dba - DBA module for PHP
php7.3-dev - Files for PHP7.3 module development
php7.3-enchant - Enchant module for PHP
php7.3-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php7.3-gd - GD module for PHP
php7.3-gmp - GMP module for PHP
php7.3-imap - IMAP module for PHP
php7.3-interbase - Interbase module for PHP
php7.3-intl - Internationalisation module for PHP
php7.3-json - JSON module for PHP
php7.3-ldap - LDAP module for PHP
php7.3-mbstring - MBSTRING module for PHP
php7.3-mysql - MySQL module for PHP
php7.3-odbc - ODBC module for PHP
php7.3-opcache - Zend OpCache module for PHP
php7.3-pgsql - PostgreSQL module for PHP
php7.3-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
php7.3-pspell - pspell module for PHP
php7.3-readline - readline module for PHP
php7.3-recode - recode module for PHP
php7.3-snmp - SNMP module for PHP
php7.3-soap - SOAP module for PHP
php7.3-sqlite3 - SQLite3 module for PHP
php7.3-sybase - Sybase module for PHP
php7.3-tidy - tidy module for PHP
php7.3-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
php7.3-xmlrpc - XMLRPC-EPI module for PHP
php7.3-zip - Zip module for PHP
php7.3-xsl - XSL module for PHP (dummy)
php7.3 - server-side, HTML-embedded scripting language (metapackage)
silosix@M6500:/usr/lib/php/20170718$ cd ~
silosix@M6500:~$ cd git/phpunitwebdriver/
silosix@M6500:~/git/phpunitwebdriver$ php composer-setup.php
PHP Warning:  PHP Startup: Unable to load dynamic library 'bz2' (tried: //usr/lib/php/20170718/bz2 (//usr/lib/php/20170718/bz2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/bz2.so (//usr/lib/php/20170718/bz2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'gd2' (tried: //usr/lib/php/20170718/gd2 (//usr/lib/php/20170718/gd2: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/gd2.so (//usr/lib/php/20170718/gd2.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'openssl' (tried: //usr/lib/php/20170718/openssl (//usr/lib/php/20170718/openssl: cannot open shared object file: No such file or directory), //usr/lib/php/20170718/openssl.so (//usr/lib/php/20170718/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP Warning:  Module 'mbstring' already loaded in Unknown on line 0
All settings correct for using Composer
Downloading...

Composer (version 1.8.0) successfully installed to: /home/silosix/git/phpunitwebdriver/composer.phar
Use it: php composer.phar

silosix@M6500:~/git/phpunitwebdriver$ ls
bin            composer.lock  composer.phar.temp  composer-setup.php.temp  README.md  tests
composer.json  composer.phar  composer-setup.php  phpunit.xml              src

 

 

 

 

 

======================================================================================
GIT PHPUnitWebDriver Composers Install

======================================================================================
======================================================================================

======================================================================================
Got git...

 

Still had issues running phpunit
sudo apt-get install php7.2-gd php7.2-bz
======================================================================================
silosix@M6500:~/git/phpunitwebdriver$ sudo apt-get install php7.2-gd php7.2-bz
[sudo] password for silosix:             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.2-bz2' for regex 'php7.2-bz'
php7.2-gd is already the newest version (7.2.13-1+ubuntu18.04.1+deb.sury.org+1).
php7.2-gd set to manually installed.
The following NEW packages will be installed:
  php7.2-bz2
0 upgraded, 1 newly installed, 0 to remove and 98 not upgraded.
Need to get 10.2 kB of archives.
After this operation, 53.2 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.2-bz2 amd64 7.2.13-1+ubuntu18.04.1+deb.sury.org+1 [10.2 kB]
Fetched 10.2 kB in 1s (15.9 kB/s)                  
Selecting previously unselected package php7.2-bz2.
(Reading database ... 267276 files and directories currently installed.)
Preparing to unpack .../php7.2-bz2_7.2.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.2-bz2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for php7.2-fpm (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.2-bz2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

Creating config file /etc/php/7.2/mods-available/bz2.ini with new version
Processing triggers for libapache2-mod-php7.2 (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Warning: Could not load Apache 2.4 maintainer script helper.
Processing triggers for php7.2-fpm (7.2.13-1+ubuntu18.04.1+deb.sury.org+1) ...

======================================================================================

 


======================================================================================
Mint m19.dev : VirtualBox Guest Additions update on Guest
======================================================================================

sudo apt-get update
sudo apt install linux-headers-$(uname -r) build-essential dkms

 

setup@m19-dev:~$ sudo apt install linux-headers-$(uname -r) build-essential dkmsReading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-4.15.0-20-generic is already the newest version (4.15.0-20.21).
The following additional packages will be installed:
  g++ g++-7 libc-dev-bin libc6-dev libstdc++-7-dev
Suggested packages:
  menu g++-multilib g++-7-multilib gcc-7-doc libstdc++6-7-dbg glibc-doc
  libstdc++-7-doc
The following NEW packages will be installed:
  build-essential g++ g++-7 libc-dev-bin libc6-dev libstdc++-7-dev
The following packages will be upgraded:
  dkms
1 upgraded, 6 newly installed, 0 to remove and 159 not upgraded.
Need to get 68.2 kB/11.8 MB of archives.
After this operation, 60.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Ign:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 dkms all 2.3-3ubuntu9.1
Err:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 dkms all 2.3-3ubuntu9.1
  404  Not Found [IP: 91.189.88.149 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/d/dkms/dkms_2.3-3ubuntu9.1_all.deb  404  Not Found [IP: 91.189.88.149 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
setup@m19-dev:~$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tara InRelease
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]    
Get:3 http://packages.linuxmint.com tara Release [24.1 kB]                     
Hit:4 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Get:5 http://packages.linuxmint.com tara Release.gpg [819 B]                   
Get:6 http://archive.canonical.com/ubuntu bionic InRelease [10.2 kB]           
Get:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]      
Get:8 http://packages.linuxmint.com tara/main amd64 Packages [13.5 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]    
Get:10 http://packages.linuxmint.com tara/main i386 Packages [12.9 kB]         
Get:11 http://packages.linuxmint.com tara/upstream i386 Packages [32.2 kB]
Get:12 http://archive.canonical.com/ubuntu bionic/partner amd64 Packages [2,308 B]
Get:13 http://packages.linuxmint.com tara/upstream amd64 Packages [32.2 kB]    
Get:14 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [178 kB]
Get:15 http://archive.canonical.com/ubuntu bionic/partner i386 Packages [2,300 B]
Get:16 http://packages.linuxmint.com tara/import i386 Packages [2,730 B]       
Get:17 http://packages.linuxmint.com tara/import amd64 Packages [3,655 B]      
Get:18 http://packages.linuxmint.com tara/backport i386 Packages [29.5 kB]     
Get:19 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [235 kB]
Get:20 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [413 kB]
Get:21 http://packages.linuxmint.com tara/backport amd64 Packages [29.5 kB]    
Get:22 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [88.9 kB]
Get:23 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:24 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [107 kB]
Get:25 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [110 kB]
Get:26 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [62.2 kB]
Get:27 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.8 kB]
Get:28 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [1,440 B]
Get:29 http://security.ubuntu.com/ubuntu bionic-security/multiverse i386 Packages [1,608 B]
Get:30 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [996 B]
Get:31 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [476 kB]
Get:32 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [177 kB]
Get:33 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]
Get:34 http://archive.ubuntu.com/ubuntu bionic-updates/restricted i386 Packages [6,928 B]
Get:35 http://archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [6,992 B]
Get:36 http://archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [3,076 B]
Get:37 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [706 kB]
Get:38 http://archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [698 kB]
Get:39 http://archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [171 kB]
Get:40 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]
Get:41 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [6,372 B]
Get:42 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [6,524 B]
Get:43 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse Translation-en [3,356 B]
Get:44 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:45 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [3,468 B]
Get:46 http://archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [3,476 B]
Get:47 http://archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [1,604 B]
Get:48 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]
Fetched 4,380 kB in 3s (1,511 kB/s)              
Reading package lists... Done
setup@m19-dev:~$ sudo apt install linux-headers-$(uname -r) build-essential dkmsReading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-4.15.0-20-generic is already the newest version (4.15.0-20.21).
The following additional packages will be installed:
  cpp cpp-7 g++ g++-7 gcc gcc-7 gcc-7-base libasan4 libc-dev-bin libc6-dev
  libcilkrts5 libgcc-7-dev libgfortran4 libstdc++-7-dev libubsan0
Suggested packages:
  cpp-doc gcc-7-locales menu g++-multilib g++-7-multilib gcc-7-doc
  libstdc++6-7-dbg gcc-multilib autoconf automake libtool gcc-doc
  gcc-7-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg
  libasan4-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg
  libmpx2-dbg libquadmath0-dbg glibc-doc libstdc++-7-doc
The following NEW packages will be installed:
  build-essential g++ g++-7 libc-dev-bin libc6-dev libstdc++-7-dev
The following packages will be upgraded:
  cpp cpp-7 dkms gcc gcc-7 gcc-7-base libasan4 libcilkrts5 libgcc-7-dev
  libgfortran4 libubsan0
11 upgraded, 6 newly installed, 0 to remove and 563 not upgraded.
Need to get 26.7 MB/29.4 MB of archives.
After this operation, 60.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libubsan0 amd64 7.3.0-27ubuntu1~18.04 [126 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgfortran4 amd64 7.3.0-27ubuntu1~18.04 [492 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libasan4 amd64 7.3.0-27ubuntu1~18.04 [358 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcilkrts5 amd64 7.3.0-27ubuntu1~18.04 [42.5 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7 amd64 7.3.0-27ubuntu1~18.04 [7,455 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgcc-7-dev amd64 7.3.0-27ubuntu1~18.04 [2,380 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 cpp-7 amd64 7.3.0-27ubuntu1~18.04 [6,738 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7-base amd64 7.3.0-27ubuntu1~18.04 [18.9 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 cpp amd64 4:7.3.0-3ubuntu2.1 [27.6 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc amd64 4:7.3.0-3ubuntu2.1 [5,184 B]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libstdc++-7-dev amd64 7.3.0-27ubuntu1~18.04 [1,463 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 g++-7 amd64 7.3.0-27ubuntu1~18.04 [7,570 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 g++ amd64 4:7.3.0-3ubuntu2.1 [1,572 B]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 dkms all 2.3-3ubuntu9.2 [68.0 kB]
Fetched 26.7 MB in 3s (9,307 kB/s)
Selecting previously unselected package libc-dev-bin.
(Reading database ... 235917 files and directories currently installed.)
Preparing to unpack .../00-libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
Unpacking libc-dev-bin (2.27-3ubuntu1) ...
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack .../01-libc6-dev_2.27-3ubuntu1_amd64.deb ...
Unpacking libc6-dev:amd64 (2.27-3ubuntu1) ...
Preparing to unpack .../02-libubsan0_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libubsan0:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../03-libgfortran4_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libgfortran4:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../04-libasan4_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libasan4:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../05-libcilkrts5_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libcilkrts5:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../06-gcc-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking gcc-7 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../07-libgcc-7-dev_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libgcc-7-dev:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../08-cpp-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking cpp-7 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../09-gcc-7-base_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking gcc-7-base:amd64 (7.3.0-27ubuntu1~18.04) over (7.3.0-16ubuntu3) ...
Preparing to unpack .../10-cpp_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking cpp (4:7.3.0-3ubuntu2.1) over (4:7.3.0-3ubuntu2) ...
Preparing to unpack .../11-gcc_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking gcc (4:7.3.0-3ubuntu2.1) over (4:7.3.0-3ubuntu2) ...
Selecting previously unselected package libstdc++-7-dev:amd64.
Preparing to unpack .../12-libstdc++-7-dev_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking libstdc++-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package g++-7.
Preparing to unpack .../13-g++-7_7.3.0-27ubuntu1~18.04_amd64.deb ...
Unpacking g++-7 (7.3.0-27ubuntu1~18.04) ...
Selecting previously unselected package g++.
Preparing to unpack .../14-g++_4%3a7.3.0-3ubuntu2.1_amd64.deb ...
Unpacking g++ (4:7.3.0-3ubuntu2.1) ...
Selecting previously unselected package build-essential.
Preparing to unpack .../15-build-essential_12.4ubuntu1_amd64.deb ...
Unpacking build-essential (12.4ubuntu1) ...
Preparing to unpack .../16-dkms_2.3-3ubuntu9.2_all.deb ...
Unpacking dkms (2.3-3ubuntu9.2) over (2.3-3ubuntu9) ...
Setting up gcc-7-base:amd64 (7.3.0-27ubuntu1~18.04) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libc-dev-bin (2.27-3ubuntu1) ...
Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
Setting up libasan4:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libgfortran4:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libcilkrts5:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libubsan0:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up libgcc-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up cpp-7 (7.3.0-27ubuntu1~18.04) ...
Setting up libstdc++-7-dev:amd64 (7.3.0-27ubuntu1~18.04) ...
Setting up cpp (4:7.3.0-3ubuntu2.1) ...
Setting up gcc-7 (7.3.0-27ubuntu1~18.04) ...
Setting up g++-7 (7.3.0-27ubuntu1~18.04) ...
Setting up gcc (4:7.3.0-3ubuntu2.1) ...
Setting up dkms (2.3-3ubuntu9.2) ...
Setting up g++ (4:7.3.0-3ubuntu2.1) ...
update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode
Setting up build-essential (12.4ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

 

INSERT GUEST ADDITIONS 5.2.22
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.18 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 5.2.12 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.  This may take a while.
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
Press Return to close this window...


======================================================================================

 

======================================================================================
Git
======================================================================================
setup@m19-dev:/$ sudo apt install git
[sudo] password for setup:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  git-man liberror-perl
Suggested packages:
  git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk
  gitweb git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
  git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 562 not upgraded.
Need to get 4,733 kB of archives.
After this operation, 33.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 liberror-perl all 0.17025-1 [22.8 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 git-man all 1:2.17.1-1ubuntu0.4 [803 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 git amd64 1:2.17.1-1ubuntu0.4 [3,907 kB]
Fetched 4,733 kB in 2s (2,593 kB/s)
Selecting previously unselected package liberror-perl.
(Reading database ... 237722 files and directories currently installed.)
Preparing to unpack .../liberror-perl_0.17025-1_all.deb ...
Unpacking liberror-perl (0.17025-1) ...
Selecting previously unselected package git-man.
Preparing to unpack .../git-man_1%3a2.17.1-1ubuntu0.4_all.deb ...
Unpacking git-man (1:2.17.1-1ubuntu0.4) ...
Selecting previously unselected package git.
Preparing to unpack .../git_1%3a2.17.1-1ubuntu0.4_amd64.deb ...
Unpacking git (1:2.17.1-1ubuntu0.4) ...
Setting up git-man (1:2.17.1-1ubuntu0.4) ...
Setting up liberror-perl (0.17025-1) ...
Processing triggers for man-db (2.8.3-
======================================================================================

 


======================================================================================
PHP7.2
sudo apt install php7.2-cli
Creating config file /etc/php/7.2/cli/php.ini with new version
PHP VM UTIL: sudo apt install hhv
#apt-get install php-pear php-fpm php-dev php-zip php-curl php-xmlrpc php-gd php-mysql php-mbstring php-xml libapache2-mod-php
#apt-get install php7.2-gd php7.2-bz
apt-get install php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml php7.2-bz


Folders:
/usr/share/php7.2-common
/usr/lib/php/20170718
/etc/php/7.2
/usr/include/php/20170718/*

extension_dir = "/usr/lib/php/2017
======================================================================================
  sudo apt-get install python-software-properties
  sudo add-apt-repository ppa:ondrej/php
  sudo apt-get update
  sudo apt-get install -y php7.2
  apt-cache search --names-only ^php


==================================================
    Might Try some of these???
    ==================================================


setup@m19-dev:~/git/phpunitwebdriver$ php -version

Command 'php' not found, but can be installed with:

sudo apt install php7.2-cli
sudo apt install hhvm      

setup@m19-dev:~/git/phpunitwebdriver$ sudo apt install php7.2-cli
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  php-common php7.2-common php7.2-json php7.2-opcache php7.2-readline
Suggested packages:
  php-pear
The following NEW packages will be installed:
  php-common php7.2-cli php7.2-common php7.2-json php7.2-opcache
  php7.2-readline
0 upgraded, 6 newly installed, 0 to remove and 562 not upgraded.
Need to get 2,490 kB of archives.
After this operation, 12.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 php-common all 1:60ubuntu1 [12.1 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-common amd64 7.2.10-0ubuntu0.18.04.1 [878 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-json amd64 7.2.10-0ubuntu0.18.04.1 [18.8 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-opcache amd64 7.2.10-0ubuntu0.18.04.1 [165 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-readline amd64 7.2.10-0ubuntu0.18.04.1 [12.1 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-cli amd64 7.2.10-0ubuntu0.18.04.1 [1,405 kB]
Fetched 2,490 kB in 3s (980 kB/s)     
Selecting previously unselected package php-common.
(Reading database ... 238629 files and directories currently installed.)
Preparing to unpack .../0-php-common_1%3a60ubuntu1_all.deb ...
Unpacking php-common (1:60ubuntu1) ...
Selecting previously unselected package php7.2-common.
Preparing to unpack .../1-php7.2-common_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-common (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-json.
Preparing to unpack .../2-php7.2-json_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-json (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-opcache.
Preparing to unpack .../3-php7.2-opcache_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-opcache (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-readline.
Preparing to unpack .../4-php7.2-readline_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-readline (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-cli.
Preparing to unpack .../5-php7.2-cli_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-cli (7.2.10-0ubuntu0.18.04.1) ...
Setting up php-common (1:60ubuntu1) ...
Created symlink /etc/systemd/system/timers.target.wants/phpsessionclean.timer → /lib/systemd/system/phpsessionclean.timer.
Processing triggers for man-db (2.8.3-2) ...
Setting up php7.2-common (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/calendar.ini with new version

Creating config file /etc/php/7.2/mods-available/ctype.ini with new version

Creating config file /etc/php/7.2/mods-available/exif.ini with new version

Creating config file /etc/php/7.2/mods-available/fileinfo.ini with new version

Creating config file /etc/php/7.2/mods-available/ftp.ini with new version

Creating config file /etc/php/7.2/mods-available/gettext.ini with new version

Creating config file /etc/php/7.2/mods-available/iconv.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo.ini with new version

Creating config file /etc/php/7.2/mods-available/phar.ini with new version

Creating config file /etc/php/7.2/mods-available/posix.ini with new version

Creating config file /etc/php/7.2/mods-available/shmop.ini with new version

Creating config file /etc/php/7.2/mods-available/sockets.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvsem.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvshm.ini with new version

Creating config file /etc/php/7.2/mods-available/tokenizer.ini with new version
Setting up php7.2-readline (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/readline.ini with new version
Setting up php7.2-json (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/json.ini with new version
Setting up php7.2-opcache (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/opcache.ini with new version
Setting up php7.2-cli (7.2.10-0ubuntu0.18.04.1) ...
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in auto mode
update-alternatives: using /usr/bin/phar7.2 to provide /usr/bin/phar (phar) in auto mode
update-alternatives: using /usr/bin/phar.phar7.2 to provide /usr/bin/phar.phar (phar.phar) in auto mode

Creating config file /etc/php/7.2/cli/php.ini with new version
    
======================================================================================
setup@m19-dev:~/git/phpunitwebdriver$ sudo apt-get install php7.2-curl php7.2-dev php7.2-gd php7.2-mbstring php7.2-zip php7.2-mysql php7.2-xml php7.2-bz
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.2-bz2' for regex 'php7.2-bz'
The following additional packages will be installed:
  autoconf automake autotools-dev libpcre16-3 libpcre3-dev libpcre32-3
  libpcrecpp0v5 libssl-dev libssl1.1 libtool shtool
Suggested packages:
  autoconf-archive gnu-standards autoconf-doc libtool-doc gfortran
  | fortran95-compiler gcj-jdk dh-php
Recommended packages:
  libssl-doc libltdl-dev pkg-php-tools
The following NEW packages will be installed:
  autoconf automake autotools-dev libpcre16-3 libpcre3-dev libpcre32-3
  libpcrecpp0v5 libssl-dev libtool php7.2-bz2 php7.2-curl php7.2-dev php7.2-gd
  php7.2-mbstring php7.2-mysql php7.2-xml php7.2-zip shtool
The following packages will be upgraded:
  libssl1.1
1 upgraded, 18 newly installed, 0 to remove and 561 not upgraded.
Need to get 5,876 kB of archives.
After this operation, 24.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libssl1.1 amd64 1.1.0g-2ubuntu4.3 [1,130 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/main amd64 autoconf all 2.69-11 [322 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 autotools-dev all 20180224.1 [39.6 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 automake all 1:1.15.1-3ubuntu2 [509 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpcre16-3 amd64 2:8.39-9 [147 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpcre32-3 amd64 2:8.39-9 [138 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpcrecpp0v5 amd64 2:8.39-9 [15.3 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpcre3-dev amd64 2:8.39-9 [537 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libssl-dev amd64 1.1.0g-2ubuntu4.3 [1,374 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic/main amd64 libtool all 2.4.6-2 [194 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 php7.2-bz2 amd64 7.2.10-0ubuntu0.18.04.1 [10.2 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-curl amd64 7.2.10-0ubuntu0.18.04.1 [28.9 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic/main amd64 shtool all 2.0.8-9 [121 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-dev amd64 7.2.10-0ubuntu0.18.04.1 [555 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-gd amd64 7.2.10-0ubuntu0.18.04.1 [27.1 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 php7.2-mbstring amd64 7.2.10-0ubuntu0.18.04.1 [483 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-mysql amd64 7.2.10-0ubuntu0.18.04.1 [118 kB]
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-xml amd64 7.2.10-0ubuntu0.18.04.1 [107 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 php7.2-zip amd64 7.2.10-0ubuntu0.18.04.1 [20.3 kB]
Fetched 5,876 kB in 3s (2,264 kB/s)     
Preconfiguring packages ...
(Reading database ... 238748 files and directories currently installed.)
Preparing to unpack .../libssl1.1_1.1.0g-2ubuntu4.3_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.0g-2ubuntu4.3) over (1.1.0g-2ubuntu4) ...
Setting up libssl1.1:amd64 (1.1.0g-2ubuntu4.3) ...
Selecting previously unselected package autoconf.
(Reading database ... 238748 files and directories currently installed.)
Preparing to unpack .../00-autoconf_2.69-11_all.deb ...
Unpacking autoconf (2.69-11) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../01-autotools-dev_20180224.1_all.deb ...
Unpacking autotools-dev (20180224.1) ...
Selecting previously unselected package automake.
Preparing to unpack .../02-automake_1%3a1.15.1-3ubuntu2_all.deb ...
Unpacking automake (1:1.15.1-3ubuntu2) ...
Selecting previously unselected package libpcre16-3:amd64.
Preparing to unpack .../03-libpcre16-3_2%3a8.39-9_amd64.deb ...
Unpacking libpcre16-3:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcre32-3:amd64.
Preparing to unpack .../04-libpcre32-3_2%3a8.39-9_amd64.deb ...
Unpacking libpcre32-3:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcrecpp0v5:amd64.
Preparing to unpack .../05-libpcrecpp0v5_2%3a8.39-9_amd64.deb ...
Unpacking libpcrecpp0v5:amd64 (2:8.39-9) ...
Selecting previously unselected package libpcre3-dev:amd64.
Preparing to unpack .../06-libpcre3-dev_2%3a8.39-9_amd64.deb ...
Unpacking libpcre3-dev:amd64 (2:8.39-9) ...
Selecting previously unselected package libssl-dev:amd64.
Preparing to unpack .../07-libssl-dev_1.1.0g-2ubuntu4.3_amd64.deb ...
Unpacking libssl-dev:amd64 (1.1.0g-2ubuntu4.3) ...
Selecting previously unselected package libtool.
Preparing to unpack .../08-libtool_2.4.6-2_all.deb ...
Unpacking libtool (2.4.6-2) ...
Selecting previously unselected package php7.2-bz2.
Preparing to unpack .../09-php7.2-bz2_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-bz2 (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-curl.
Preparing to unpack .../10-php7.2-curl_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-curl (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package shtool.
Preparing to unpack .../11-shtool_2.0.8-9_all.deb ...
Unpacking shtool (2.0.8-9) ...
Selecting previously unselected package php7.2-dev.
Preparing to unpack .../12-php7.2-dev_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-dev (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-gd.
Preparing to unpack .../13-php7.2-gd_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-gd (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-mbstring.
Preparing to unpack .../14-php7.2-mbstring_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-mbstring (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-mysql.
Preparing to unpack .../15-php7.2-mysql_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-mysql (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-xml.
Preparing to unpack .../16-php7.2-xml_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-xml (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php7.2-zip.
Preparing to unpack .../17-php7.2-zip_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-zip (7.2.10-0ubuntu0.18.04.1) ...
Setting up php7.2-mysql (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.2/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo_mysql.ini with new version
Setting up php7.2-gd (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/gd.ini with new version
Setting up php7.2-xml (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/dom.ini with new version

Creating config file /etc/php/7.2/mods-available/simplexml.ini with new version

Creating config file /etc/php/7.2/mods-available/wddx.ini with new version

Creating config file /etc/php/7.2/mods-available/xml.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlreader.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlwriter.ini with new version

Creating config file /etc/php/7.2/mods-available/xsl.ini with new version
Setting up php7.2-zip (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/zip.ini with new version
Setting up php7.2-curl (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/curl.ini with new version
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up shtool (2.0.8-9) ...
Setting up libssl-dev:amd64 (1.1.0g-2ubuntu4.3) ...
Setting up autoconf (2.69-11) ...
Setting up php7.2-mbstring (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/mbstring.ini with new version
Setting up php7.2-bz2 (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/bz2.ini with new version
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up autotools-dev (20180224.1) ...
Processing triggers for doc-base (0.10.8) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Setting up automake (1:1.15.1-3ubuntu2) ...
update-alternatives: using /usr/bin/automake-1.15 to provide /usr/bin/automake (automake) in auto mode
Processing triggers for man-db (2.8.3-2) ...
Setting up libpcrecpp0v5:amd64 (2:8.39-9) ...
Setting up libpcre32-3:amd64 (2:8.39-9) ...
Setting up libpcre16-3:amd64 (2:8.39-9) ...
Setting up libtool (2.4.6-2) ...
Setting up libpcre3-dev:amd64 (2:8.39-9) ...
Setting up php7.2-dev (7.2.10-0ubuntu0.18.04.1) ...
update-alternatives: using /usr/bin/php-config7.2 to provide /usr/bin/php-config (php-config) in auto mode
update-alternatives: using /usr/bin/phpize7.2 to provide /usr/bin/phpize (phpize) in auto mode
Processing triggers for libc-bin (2.27-3ubuntu1) ...

======================================================================================
VM phpunitwebdriver
======================================================================================
setup@m19-dev:/$ php -version
PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

 

setup@m19-dev:~/git/phpunitwebdriver$ php composer.phar install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 64 installs, 0 updates, 0 removals
  - Installing behat/gherkin (v4.5.1): Downloading (100%)         
  - Installing symfony/polyfill-mbstring (v1.10.0): Downloading (100%)         
  - Installing symfony/polyfill-ctype (v1.10.0): Downloading (100%)         
  - Installing symfony/dom-crawler (v4.1.8): Downloading (100%)         
  - Installing symfony/browser-kit (v4.1.8): Downloading (100%)         
  - Installing symfony/css-selector (v3.4.19): Downloading (100%)         
  - Installing behat/mink (v1.7.1): Downloading (100%)         
  - Installing behat/mink-browserkit-driver (1.3.3): Downloading (100%)         
  - Installing behat/transliterator (v1.2.0): Downloading (100%)         
  - Installing psr/container (1.0.0): Downloading (100%)         
  - Installing container-interop/container-interop (1.2.0): Downloading (100%)         
  - Installing symfony/polyfill-iconv (v1.10.0): Downloading (100%)         
  - Installing paragonie/random_compat (v2.0.17): Downloading (100%)         
  - Installing drupal/core-utility (8.6.3): Downloading (100%)         
  - Installing drupal/core-render (8.6.3): Downloading (100%)         
  - Installing symfony/event-dispatcher (v3.4.19): Downloading (100%)         
  - Installing symfony/dependency-injection (v3.4.19): Downloading (100%)         
  - Installing symfony/process (v3.4.19): Downloading (100%)         
  - Installing drupal/drupal-driver (v1.4.0): Downloading (100%)         
  - Installing instaclick/php-webdriver (1.4.5): Downloading (100%)         
  - Installing behat/mink-selenium2-driver (v1.3.1): Downloading (100%)         
  - Installing psr/http-message (1.0.1): Downloading (100%)         
  - Installing guzzlehttp/psr7 (1.4.2): Downloading (100%)         
  - Installing guzzlehttp/promises (v1.3.1): Downloading (100%)         
  - Installing guzzlehttp/guzzle (dev-master 8db1967): Cloning 8db1967d92 from cache
  - Installing fabpot/goutte (v3.2.3): Downloading (100%)         
  - Installing behat/mink-goutte-driver (v1.2.1): Downloading (100%)         
  - Installing symfony/filesystem (v4.1.8): Downloading (100%)         
  - Installing symfony/config (v4.1.8): Downloading (100%)         
  - Installing symfony/yaml (v4.1.8): Downloading (100%)         
  - Installing symfony/translation (v4.1.8): Downloading (100%)         
  - Installing symfony/console (v4.1.8): Downloading (100%)         
  - Installing symfony/class-loader (v3.4.19): Downloading (100%)         
  - Installing behat/behat (v3.5.0): Downloading (100%)         
    Skipped installation of bin bin/behat for package behat/behat: name conflicts with an existing file
  - Installing behat/mink-extension (2.3.1): Downloading (100%)         
  - Installing drupal/drupal-extension (v3.4.1): Downloading (100%)         
  - Installing facebook/webdriver (1.6.0): Downloading (100%)         
  - Installing webmozart/assert (1.3.0): Downloading (100%)         
  - Installing phpdocumentor/reflection-common (1.0.1): Downloading (100%)         
  - Installing phpdocumentor/type-resolver (0.4.0): Downloading (100%)         
  - Installing phpdocumentor/reflection-docblock (4.3.0): Downloading (100%)         
  - Installing phpunit/php-token-stream (3.0.1): Downloading (100%)         
  - Installing sebastian/version (2.0.1): Downloading (100%)         
  - Installing sebastian/resource-operations (2.0.1): Downloading (100%)         
  - Installing sebastian/recursion-context (3.0.0): Downloading (100%)         
  - Installing sebastian/object-reflector (1.1.1): Downloading (100%)         
  - Installing sebastian/object-enumerator (3.0.3): Downloading (100%)         
  - Installing sebastian/global-state (2.0.0): Downloading (100%)         
  - Installing sebastian/exporter (3.1.0): Downloading (100%)         
  - Installing sebastian/environment (4.0.1): Downloading (100%)         
  - Installing sebastian/diff (3.0.1): Downloading (100%)         
  - Installing sebastian/comparator (3.0.2): Downloading (100%)         
  - Installing phpunit/php-timer (2.0.0): Downloading (100%)         
  - Installing phpunit/php-text-template (1.2.1): Downloading (100%)         
  - Installing phpunit/php-file-iterator (2.0.2): Downloading (100%)         
  - Installing theseer/tokenizer (1.1.0): Downloading (100%)         
  - Installing sebastian/code-unit-reverse-lookup (1.0.1): Downloading (100%)         
  - Installing phpunit/php-code-coverage (6.1.4): Downloading (100%)         
  - Installing doctrine/instantiator (1.1.0): Downloading (100%)         
  - Installing phpspec/prophecy (1.8.0): Downloading (100%)         
  - Installing phar-io/version (2.0.1): Downloading (100%)         
  - Installing phar-io/manifest (1.0.3): Downloading (100%)         
  - Installing myclabs/deep-copy (1.8.1): Downloading (100%)         
  - Installing phpunit/phpunit (7.4.4): Downloading (100%)         
    Skipped installation of bin phpunit for package phpunit/phpunit: name conflicts with an existing file
behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled headless driver for any app (requires node.js))
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
symfony/event-dispatcher suggests installing symfony/http-kernel
symfony/dependency-injection suggests installing symfony/expression-language (For using expressions in service container configuration)
symfony/dependency-injection suggests installing symfony/finder (For using double-star glob patterns or when GLOB_BRACE portability is required)
symfony/dependency-injection suggests installing symfony/proxy-manager-bridge (Generate service proxies to lazy load them)
guzzlehttp/guzzle suggests installing psr/log (Required for using the Log middleware)
symfony/translation suggests installing psr/log-implementation (To use logging capability in translator)
symfony/console suggests installing psr/log-implementation (For using the console logger)
symfony/console suggests installing symfony/lock
symfony/class-loader suggests installing symfony/polyfill-apcu (For using ApcClassLoader on HHVM)
facebook/webdriver suggests installing ext-SimpleXML (For Firefox profile creation)
sebastian/global-state suggests installing ext-uopz (*)
phpunit/php-code-coverage suggests installing ext-xdebug (^2.6.0)
phpunit/phpunit suggests installing ext-soap (*)
phpunit/phpunit suggests installing ext-xdebug (*)
phpunit/phpunit suggests installing phpunit/php-invoker (^2.0)
Generating autoload files

======================================================================================


======================================================================================
VM Sublime Merge
======================================================================================
Add GPG key
wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -

set apt to work with https sources
sudo apt-get install apt-transport-https

select channel to use:
echo "deb https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list
echo "deb https://download.sublimetext.com/ apt/dev/" | sudo tee /etc/apt/sources.list.d/sublime-text.list

update apt sources & install Sublime Merge
sudo apt-get update
sudo apt-get install sublime-merge


======================================================================================
setup@m19-dev:~$ sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 561 not upgraded.
Need to get 1,692 B of archives.
After this operation, 152 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 apt-transport-https all 1.6.6 [1,692 B]
Fetched 1,692 B in 2s (988 B/s)                      
Selecting previously unselected package apt-transport-https.
(Reading database ... 239701 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_1.6.6_all.deb ...
Unpacking apt-transport-https (1.6.6) ...
Setting up apt-transport-https (1.6.6) ..

 

setup@m19-dev:~$ sudo apt-get update
Hit:1 http://archive.canonical.com/ubuntu bionic InRelease
Get:2 https://download.sublimetext.com apt/stable/ InRelease [2,562 B]         
Ign:3 http://packages.linuxmint.com tara InRelease                             
Hit:4 http://packages.linuxmint.com tara Release                               
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Err:2 https://download.sublimetext.com apt/stable/ InRelease                   
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F57D4F59BD3DF454
Hit:6 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]      
Get:9 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.9 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]   
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:15 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]
Reading package lists... Done                                                
W: GPG error: https://download.sublimetext.com apt/stable/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F57D4F59BD3DF454
E: The repository 'https://download.sublimetext.com apt/stable/ InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
setup@m19-dev:~$ wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
OK
setup@m19-dev:~$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tara InRelease
Hit:2 http://packages.linuxmint.com tara Release                                                                                                                                                                       
Hit:3 http://archive.canonical.com/ubuntu bionic InRelease                                                                                                                                                             
Get:4 https://download.sublimetext.com apt/stable/ InRelease [2,562 B]                                                                                 
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease                                           
Hit:7 http://archive.ubuntu.com/ubuntu bionic InRelease                  
Get:8 https://download.sublimetext.com apt/stable/ Packages [1,006 B]    
Hit:9 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                      
Hit:10 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Fetched 1,006 B in 2s (585 B/s)
Reading package lists... Done

 

setup@m19-dev:~$ sudo apt-get install sublime-merge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  sublime-merge
0 upgraded, 1 newly installed, 0 to remove and 561 not upgraded.
Need to get 4,103 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
Get:1 https://download.sublimetext.com apt/stable/ sublime-merge 1097 [4,103 kB]
Fetched 4,103 kB in 1s (5,254 kB/s)
Selecting previously unselected package sublime-merge.
(Reading database ... 239705 files and directories currently installed.)
Preparing to unpack .../sublime-merge_1097_amd64.deb ...
Unpacking sublime-merge (1097) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint2) ...
Setting up sublime-merge (1097) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...

 


======================================================================================
SUBLIME MERGE on M6500A MAIN
======================================================================================
silosix@M6500:~$ wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
[sudo] password for silosix:             
OK
silosix@M6500:~$ sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 98 not upgraded.
Need to get 1,692 B of archives.
After this operation, 152 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 apt-transport-https all 1.6.6 [1,692 B]
Fetched 1,692 B in 0s (5,760 B/s)               
Selecting previously unselected package apt-transport-https.
(Reading database ... 267285 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_1.6.6_all.deb ...
Unpacking apt-transport-https (1.6.6) ...
Setting up apt-transport-https (1.6.6) ...
silosix@M6500:~$ echo "deb https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list
deb https://download.sublimetext.com/ apt/stable/
silosix@M6500:~$ sudo apt-get update
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Ign:2 http://packages.linuxmint.com tessa InRelease                                                                  
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                            
Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                                          
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                                          
Hit:6 http://archive.canonical.com/ubuntu bionic InRelease                                                           
Hit:7 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease                                                    
Hit:8 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease                                              
Get:9 https://download.sublimetext.com apt/stable/ InRelease [2,562 B]                                               
Get:10 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,242 B]                                           
Hit:11 http://packages.linuxmint.com tessa Release                                    
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [245 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [200 kB]                       
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,464 B]                    
Get:15 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5,816 B]                    
Get:16 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]                          
Get:17 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [14.9 kB]                    
Get:18 https://download.sublimetext.com apt/stable/ Packages [1,006 B]                                               
Err:10 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                     
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Reading package lists... Done                                                                                        
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
E: The repository 'https://dl.winehq.org/wine-builds/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
silosix@M6500:~$ sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree       
Reading state information... Done
apt-transport-https is already the newest version (1.6.6).
0 upgraded, 0 newly installed, 0 to remove and 98 not upgraded.
silosix@M6500:~$ sudo apt-get update
Ign:1 http://packages.linuxmint.com tessa InRelease
Get:2 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,242 B]                                            
Hit:3 http://archive.canonical.com/ubuntu bionic InRelease                                                           
Hit:4 http://packages.linuxmint.com tessa Release                                                                    
Hit:5 https://download.sublimetext.com apt/stable/ InRelease                                                         
Hit:6 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease                                                    
Hit:7 http://security.ubuntu.com/ubuntu bionic-security InRelease                              
Err:2 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                     
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Hit:8 http://archive.ubuntu.com/ubuntu bionic InRelease                                             
Hit:9 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                                     
Hit:10 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease      
Hit:12 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done                      
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
E: The repository 'https://dl.winehq.org/wine-builds/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
silosix@M6500:~$ sudo apt-get install sublime-merge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  sublime-merge
0 upgraded, 1 newly installed, 0 to remove and 98 not upgraded.
Need to get 4,103 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
Get:1 https://download.sublimetext.com apt/stable/ sublime-merge 1097 [4,103 kB]
Fetched 4,103 kB in 1s (5,139 kB/s)
Selecting previously unselected package sublime-merge.
(Reading database ... 267289 files and directories currently installed.)
Preparing to unpack .../sublime-merge_1097_amd64.deb ...
Unpacking sublime-merge (1097) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23+linuxmint4) ...
Setting up sublime-merge (1097) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
silosix@M6500:~$

======================================================================================


======================================================================================
XMPP Server

Installing Openfire on Ubuntu 18.04 / Ubuntu 16.04
$ sudo apt-get update
$ sudo apt-get upgrade

======================================================================================
======================================================================================


======================================================================================
======================================================================================
======================================================================================

 

 

 

Tags